Next Generation Emulation banner

1 - 13 of 13 Posts

·
Sage of Life, Reason,Time
Joined
·
26 Posts
Discussion Starter #1
I recently upgraded to Windows 10 with a new motherboard, RAM, CPU, and NVMe stick...
and ePSX e is not working right... it keeps crashing anytime I try to load a game..
 

·
No sir, I don't like it.
Joined
·
5,481 Posts
Make sure you have the necessary VC++ and Direct X distributables.



Amazing that after all these years Microsoft still doesn't include these commonly used components.
 

·
Sage of Life, Reason,Time
Joined
·
26 Posts
Discussion Starter #3
yeah.. its odd they don't include the VC++ runtime with Windows..
of course I did, DX 9 and all the VC++ RTE were among the first things I installed...
I noticed the other thread about crashing ePSXe.. and tried setting CPU overclocking to 1x.. that plus loading the ISOs manually seem to work had to also set to Win7 compatibility mode too... I played Wild Arms 1 for a couple of hours...
with it crashing or not responding once or twice...
 

·
Registered
Joined
·
318 Posts
Hi you there.
Well. It's been 3 years since I jumped into Windows 10, and ePSXe runs fine to me. But unfortunately; versions 1.50 and 1.60 doesn't work properly. Those versions can be opened, but on try to open any game cannot be done. However; versions 1.80 till the latest; 2.05 can be opened without any problems.

Of course, not only ePSXe got all of this issues. At some machines with W10 already installed got a lot of issues about of it's compatibilities. Even "older" PC games, Software of any kind got some compatibility issues inside upon ot this W10.

As for another people from here recommends at you; on to install and upgrade some of these C++ and another stuff. It's a great idea. I did it for my self, instead on installing another (useless) W10 updatings. Installs another Microsoft Visuals C++ prior versions. You will need it for another stuff ( not only for ePSXe ). You need somethin like .NET Framework. Specially the 3.5 version. ( it came inside at your Install Disc. But whatever it is, it won't installs, you'll need to install it by your self manually ). Some from your prior programs and softwares will be asked for this. And of course, you will need more stuff from DirectX prior versions.

And while if you can; Try to free your Windows 10. As everybody knows; Windows it's a mess and requires an a lot of your resources, always it's checkin' everything, spies at you, their "protection system" it's a REAL TOTAL MESS. You need to free your system if you want a better experience, specially, a major compatibility for your system. Specially at your gaming and maybe your working proposes.

Those things i did, and my machine flies better than a Jet !!!!!
 

·
Sage of Life, Reason,Time
Joined
·
26 Posts
Discussion Starter #5
I already took care of the .NET framework, DirectX9, and C++ runtimes.... that was not it...
ePSXe is just old and has not been updated for Windows 10...
I have tried emailing the devs but got no response...
 

·
Registered
Joined
·
318 Posts
I understand that. Assume that almost new machines and the now on Windows 10 are on 64-bits. Its almost dufficult for on try to open old kind of programs. Specially if they are for 32-bit. And ePSXe and such are old and just are available for 32-bit machines.

However. Maybe you would on turn your W10 installation for 32-bit too for compatibolty. Because, i have my own W10 install as 32-bit / 64-bit machine for a better compatibilties. And thanks for that it helped me a lot.

However. Did you said that you runs ePSXe a little and it let you plays Wild Arms? ok. Did you tried on use older versions of ePSXe such 1.80, 1.90 and 19.25.? if not. Try on use those prior versions. Maybe it would lets you. Or maybe, your video driver needs a little more configurations for a most such compatibilities. It would help you. If you have Nvidia Shield it would let you make it.
 

·
Not a Registered User
Joined
·
1,325 Posts
Here's a few tips.
In Bios settings make sure you have a proper Bios file selected, and HLE emulation is disabled.
In sound settings have latency set to normal.
In video settings set threading mode to 0, multi threading is very broken.
 

·
Sage of Life, Reason,Time
Joined
·
26 Posts
Discussion Starter #8
lol of course I have a BIOS file selected lol..
but I did have threaded set to 2... I changed it to 1...
 

·
No sir, I don't like it.
Joined
·
5,481 Posts
Change it to 0. ePSXe's multithreading is pretty garbage. If games aren't running slowly, ePSXe is crashing. Don't worry about the idea that more threads = faster. My 300MHz AMD K6-2 ran everything I threw at it in ePSXe except Final Fantasy and Chrono Cross battle swirls back in 1999, though the plugins back then weren't very good for big framebuffer effects like that. Software renderers ran fine though.
 

·
Sage of Life, Reason,Time
Joined
·
26 Posts
Discussion Starter #10
when I said I set it to 1 I meant 1 thread.. not setting 1 = 2 threads..
so I have it set to 0.. already..
 

·
Registered
Joined
·
2,158 Posts
have to check, did you make sure x1 was checked in cpu overclock?? (change it if it is then set it back)
 

·
Sage of Life, Reason,Time
Joined
·
26 Posts
Discussion Starter #12
yes CPU overclocking is set to x1
 

·
Registered
Joined
·
1 Posts
I had the same issue after trying to play tonight, I verified C++ and DirectX installations. Retested and didn't work. Installed 32 bit C++, didn't work. Set overclocking to 1x and everything worked perfectly.
 
1 - 13 of 13 Posts
Top