Next Generation Emulation banner

ePSXe keeps freezing

5351 Views 11 Replies 3 Participants Last post by  Squall-Leonhart
Okay so I downloaded ePSXe 1.70 with the bios and the up to date plugins. I put in my game disc (FF7) and it's working fine then it just freezes. So I restart the computer, put the game back in and try to play it again and my computer freezes. After about 2 minutes ePSXe pops up but nothing loads and when I go to my computer the drive for my dvd/cd isn't on there.

This has been happening to me for day so I finally gave up and decided to see if anyone can help me with this, it's driving me nuts. Whenever I go to load ePSXe for some reason my computer will freeze and then won't read the disc, or any disc for that matter. It works perfectly fine (I can watch movies and stuff from my dvd's) but as soon as I load the emulator it just messes up. So does anyone know how to fix this?
1 - 6 of 12 Posts
Well I usually use CDR WNT/W2K core and I've tried using peops but when I try to use the auto detection it says I have to do it manually? So when I did try it I just picked BE_2 and it just did the same thing. I've also tried FFVIII (FFVII is pretty scratched up) which is in pretty good condition and it does the same thing. It'll work for a little bit and then they freeze and I won't be able to play it again until the next day.

I also thought it was my DVD drive at first but it only seems to happen when I try and play a PS1 game with the emulator so I don't know what the issue is. As for the BIOS it works fine when I go to run bios it just seems to not work with the game. I've never tried to run ISO's on it either, just game's that I already have so I don't know if that would make a difference or not.
Alright, I'm about to do the test and post the results. I actually just did a system restore and tried to do run bios and this time it froze for a few minutes like it does with the games but then the memory card and cd player came up. When I did the run bios before it was with 1.6 and the second time was with 1.7. I know I played FF8 (the first game I tried) with 1.6 so I started wondering if the 1.7 version was causing issues.

Anyway, don't know if that's important or not just thought I'd mention it lol, I'm going to go run the test.
I ran the test and it didn't have any errors so still not sure what it is =/ my computer isn't reading FFVII now but at least the disc drive is showing up in my computer, it just won't load. This has been happening about every night and when I come home from work it works for a little then messes up again. I'm thinking about only using epsxe 1.60 to play games from a cd-rom so I'll have to check that out tomorrow I guess.
Ah okay I'll probably have to check that out on Friday or Saturday then. I just got this PC in May and I did upgrade the graphics card to radeon hd 4650 and I know they recommended a....350 or 300 watt and mine is only 250 or 300 (can't remember exactly what it was, I think mine was 50 under then what they recommended). I did a bunch of research on it and it's been working fine since all I really do is play WoW.

Once again I have no idea if that has anything to do with it or not, just thought I'd mention it in case it does.
Ah okay, is there anything I can do about that except get a new graphics card or change my PSU? lol. I'm pretty sure I put the old graphics card in the box the new one came in but I don't want to have to keep switching. I know with the PS2 emulator I use ISO's and never have an issue so if I used an ISO of the game's would the game still freeze?
1 - 6 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.