Next Generation Emulation banner

ePSXe generally slowing down?

3305 Views 35 Replies 8 Participants Last post by  hushypushy
Alright, I've used the emulator for a while now and its always run fine..but now the fps will drop to almost a standstill, frequently and for no particular reason.

Very annoying, to say the least.

1 - 16 of 36 Posts
this is sad

ok, first off, I run a pretty crappy 2002 dell, integrated everything, 2.19 GHz, 256 RAM, nothing above what you would find in a rather poor public library. I run from the CD (and have no diea what an ISO is, but feel I should and actually would like some info on that) I've had my ePSXe for a few months, it is the newest version, and currently am playing Final Fantasy Tactics. I haven't defragged at all, and even though everything is integrated on my computer, it has always run smoothly up until now. My FPS just bites the dust at random intervals, be it from an attack or...breathing.

I tweaked and retweaked my video configs, even changed some stuff around and set it to 'fast' instead of 'nice' with no change in the problem.

I'm not computer illiterate, but when it comes to emulation I'm what would be known as a 'horrible newbie' any help will be appreciated..

Again, whats an ISO? All my games I run from the PSX CD's that I actually own...I do have Daemon tools and use them frequently, but not for this kind of thing.
See less See more

can 3rd party ISO's be in...someone send me a game that I dont have a true disc for?
Heh, can't help but be curious, but i'll end it there. As far as antivirus stuff, I do use adaware SE and a paid subscription to norton antivirus.

My video config is Pete's OpenGL Driver 1.75, sound is ePSXe SPU core 1.5.2.

Did a defrag, is a tiny bit less glitchy but still has unexplained drops in FPS. Oh, and now when text is displayed on never leaves, just simply gets overwritten by the new text if there is ever any

Blast my Emulation incompetence!

oh, one thing that is a constant in the fps slowing is if and when the game ever fades to black, it drops to a crippling one digit FPS even when set to the fastest video configuration. Such as when I cast a spell, use an item, or launch an attack (even though it doesn't fade when you attack..)

Should I just cave and reinstall all of my ePSXe related files in an attempt to do a hard reset for it, or will that not do a thing?

Its great fun when your stupid
See less See more
here we go

As per your advice, I present....the specs

Plugin: Pete's OpenGL Driver 1.1.75
Author: Pete Bernert
Card vendor: Intel
GFX card: Intel Brookdale-G

- 640x480 Window mode
[32 Bit]- Keep psx aspect ratio: off

- R8G8B8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

- Offscreen drawing: 3
- Framebuffer texture: 2
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: off [00000000]

Somehow, this will either be a) wrong specs or b) painfully obvious to everyone but me

I'm doubting that config is correct since, even before it ran slow, the world map in game was just a massive blob of black. If you've ever played FFT you'll understand what I mean when I say just the map is black, not the city icons, paths, or my character.
See less See more

first of all, no idea what an SPU is. small words...even smaller than 3 letters..when dealing with me. now, my question is, why would the FPS drop only be a recent occurance? for several months I've been running on these settings flawlessly

Well, first of all, those video config tweaks actually seemed to of done the trick. as far as the FPS slows, those have stopped..instead, I have a more curious problem. Now it will..well..technically freeze at random intervals

The screen will continue to move, as a character will prepare an attack..sound will continue, background will continue, but FPS will drop and there will be no progression in the game..also, when a battle occurs (the classic FF swirl/fade) it will freeze temporarily at the end before launching the battle scene.

As far as the sound goes, I do think there is a potential for a problem there. It is not true sound in that, it is obviously differnt from that of the CD's intended sound. I use ePSXe SPU core 1.5.2. with 'enable sound, enable CDDA sound, Enable XA sound' selected, but not the Enable SPU IRQ.

This help any?

Well, first of all, I've yet to try PEOPs since the config tweaks that were suggested by I-Chan seemed to of effectivly fixed most of my problems and thus have stuck to his config ideas.

Second of all, I would like to express gratitude towards you all for the very effective aide I have been recieving and surprisingly quick responses to my posts. It has all bee helpful and I only wish there was some way for me to return the favor to you all...but I'm helpless so my advice will be worthless.

As for your sound suggestions, they seem to work quite well by comparison (though, 40 does lag a little, but easily fixed on my own)

ok, now that I've got my FFT finally working I've been greedy and trying to run FF9 (woo) I am indeed running it on 1.5.2 with the exact same configurations I run on my other emulator. Gameplay works fine, but the movies are very very laggy, in both sound and video. now, I can live without the if this isnt fixable, is there a way to disable them?

hey, guess what! I was wrong! if you've ever played FF9 you'll know the scenario I'm referring to - early in the game, when your airship other words, like 15 min into it if your slow. the game utterly freezes, and when I say utterly freeze I mean there is a fade-to-black scene change that anihilates ePSXe itself! one massive ball of frozen worthlessness. I make an ISO, find some miracle cure, or weep uncontrollably?

not a single one, fades to black..stays black..nothing happens, it lags if i try to minimize or put in any commands(doesn't respond anyway) and if i minimize/reopen, hte black turns to a transparent box.

So...yes on the weeping?

yes my friend, I am indeed using 1.5.2, downloaded straight from the epsxe website found in the FF9/chrono cross thread.

Anyway, I downloaded Alcohol120% and as it turns out, I'm helpless there too. anyway we can give me a brief walkthroug has to how to make an ISO?
Dobinator said:
It could be a hardware issue. How old is your CD drive, maybe it's at the end of it's legs, listen and look to see that the drive is in good working order. Things don't usually just suddenly slow down for no reason. That's the first place I'd start, then probably defrag and do other maintainance to the machine. If that doesn't work, get all new ePSXe and plugins.

See further up in the post for my comp specs, did get new plugins (completely) did defrag, and actually did get a new ePSXe. the FFT issue is solved, but the FF9 issue still stands

I-Chan, I'm naming my first born after you. you fixed my FFT issues and your advice for FF9 not only fixed the movie lag, but now the game is running very smoothly, with virtually no lag and no game-ending freezings!

me love you long time?

hehe, j/k ;) but seriously..take my son, he's a lil crybaby!

Hey, I have a brand new and very mysterious issue.

Ok, I'm running FF9 on 1.5.2 as an ISO, with all the configs previously mentioned in this threat. No changes have been made in any way or form. I made it through all of disc 1 and about half of disc 2 when there was a sudden and mysterious problem

Any text boxs are now lime green blocks. Anything save for maps/character sprites is a nice shade of puke green. Attached is a lovely picture of it, even the littel hand that floats above your head when moving is a green box.

Theoretically, I've attached a screenshot of this error, but I lack the nessecary IQ to be sure that it worked

So...I'm back to the weeping idea
1 - 16 of 36 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.