Next Generation Emulation banner

1 - 20 of 36 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Alright, I've used the emulator for a while now and its always run fine..but now the fps will drop to almost a standstill, frequently and for no particular reason.

Very annoying, to say the least.


Help?
 

·
Premium Member
Joined
·
6,341 Posts
We need more information before we can help you. What are your computer's specs? What settings are you using? Are you running your games from an ISO or from the CD?
 

·
PS2 PAL[v9], PS3Slim PAL
Joined
·
5,370 Posts
yeah, n_w95482 is right, if you'r playing from iso how long ago did you defragmented your hdd?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
this is sad

ok, first off, I run a pretty crappy 2002 dell, integrated everything, 2.19 GHz, 256 RAM, nothing above what you would find in a rather poor public library. I run from the CD (and have no diea what an ISO is, but feel I should and actually would like some info on that) I've had my ePSXe for a few months, it is the newest version, and currently am playing Final Fantasy Tactics. I haven't defragged at all, and even though everything is integrated on my computer, it has always run smoothly up until now. My FPS just bites the dust at random intervals, be it from an attack or...breathing.

I tweaked and retweaked my video configs, even changed some stuff around and set it to 'fast' instead of 'nice' with no change in the problem.

I'm not computer illiterate, but when it comes to emulation I'm what would be known as a 'horrible newbie' any help will be appreciated..


Again, whats an ISO? All my games I run from the PSX CD's that I actually own...I do have Daemon tools and use them frequently, but not for this kind of thing.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,979 Posts
well, defragment your drive then, it's not too challenging. Program files--->accessories--->system tools and pick defrag, then just run it and leave your computer alone for a bit.

what plugins are you using? try using Peops soft plugin, you can do the nice preset on that one.

an ISO is an image of your CD on your hard drive. since your hard drive has a much faster read rate than your CD drive, it makes for smoother gameplay. use a program like Alcohol120%, CloneCD, ISObuster, to make an ISO.
 

·
Premium Member
Joined
·
3,093 Posts
[rules]NO[/rules]. It's ilegal to download a game you don't own. You should check your computer for virus and/or spyware. If you don't have suitable software for that, avast is a good free antivirus, and ad-aware se works nicely for the spyware.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #9 · (Edited)
Heh, can't help but be curious, but i'll end it there. As far as antivirus stuff, I do use adaware SE and a paid subscription to norton antivirus.

My video config is Pete's OpenGL Driver 1.75, sound is ePSXe SPU core 1.5.2.

Did a defrag, is a tiny bit less glitchy but still has unexplained drops in FPS. Oh, and now when text is displayed on screen..it never leaves, just simply gets overwritten by the new text if there is ever any


Blast my Emulation incompetence!

oh, one thing that is a constant in the fps slowing is if and when the game ever fades to black, it drops to a crippling one digit FPS even when set to the fastest video configuration. Such as when I cast a spell, use an item, or launch an attack (even though it doesn't fade when you attack..)

Should I just cave and reinstall all of my ePSXe related files in an attempt to do a hard reset for it, or will that not do a thing?

Its great fun when your stupid
 

·
Premium Member
Joined
·
3,093 Posts
No, i don't think that will help. Visit kane's domain to get a nice config for epsxe. Also, you can post your current configs using the 'Copy to clipboard' button on the plugin. That will help us help you greatly, specially because it will tell us wich videocard are you using.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #11 · (Edited)
here we go

As per your advice, I present....the specs

Plugin: Pete's OpenGL Driver 1.1.75
Author: Pete Bernert
Card vendor: Intel
GFX card: Intel Brookdale-G

Resolution/Color:
- 640x480 Window mode
[32 Bit]- Keep psx aspect ratio: off

Textures:
- R8G8B8A8
- Filtering: 0
- Hi-Res textures: 0
- VRam size: 0 MBytes

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: off
- Screen cushion: off
- Game fixes: off [00000000]


Somehow, this will either be a) wrong specs or b) painfully obvious to everyone but me

I'm doubting that config is correct since, even before it ran slow, the world map in game was just a massive blob of black. If you've ever played FFT you'll understand what I mean when I say just the map is black, not the city icons, paths, or my character.
 

·
Registered
Joined
·
2,167 Posts
ummm withthe intel chipset for graphics you are better off running the P.E.O.P.S softplugin. And definately you should be running in 16 bit color mode...32 will eat ram quick on a shared ram GPU...
 

·
Premium Member
Joined
·
3,093 Posts
PEOPs will look fugly, but probably will work better. Anyway, you could try pete's DX6 D3D driver, wich you'll already have (it's included in the same package with the opengl one). I think Offscreen drawing at 2 will be enough. FB texture to 0 and FB access to 4 will stress your cpu and relieve the gfx card, wich with your setup is better. Out of curiosity, what spu plugin are you using, and how is it set up?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #14 ·
mmk..

first of all, no idea what an SPU is. small words...even smaller than 3 letters..when dealing with me. now, my question is, why would the FPS drop only be a recent occurance? for several months I've been running on these settings flawlessly
 

·
Premium Member
Joined
·
3,093 Posts
That's why i think the problem lies somewhere else, and not in the emu. Have you tried what's been posted? And SPU is the audio plugin.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #16 ·
hmm

Well, first of all, those video config tweaks actually seemed to of done the trick. as far as the FPS slows, those have stopped..instead, I have a more curious problem. Now it will..well..technically freeze at random intervals

The screen will continue to move, as a character will prepare an attack..sound will continue, background will continue, but FPS will drop and there will be no progression in the game..also, when a battle occurs (the classic FF swirl/fade) it will freeze temporarily at the end before launching the battle scene.


As far as the sound goes, I do think there is a potential for a problem there. It is not true sound in that, it is obviously differnt from that of the CD's intended sound. I use ePSXe SPU core 1.5.2. with 'enable sound, enable CDDA sound, Enable XA sound' selected, but not the Enable SPU IRQ.

This help any?
 

·
Premium Member
Joined
·
3,093 Posts
Download eternal and use that as audio plugin. Configure it to use directsound, spuasync audioout method in smooth mode, a buffer of around 40 (lower it if the sound lags, or raise it if it cracks), neill's reverb, and the first spu irq fix will probably be needed.

About the freezes, do they happen also with PEOPs?
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,979 Posts
PEops is not fugly, i think it looks rather sexy (and accurate to PSX). i set it up on my friend's computer with integrated Intel graphics, you sit back from teh monitor 3 feet and it looks good.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #19 ·
..

Well, first of all, I've yet to try PEOPs since the config tweaks that were suggested by I-Chan seemed to of effectivly fixed most of my problems and thus have stuck to his config ideas.

Second of all, I would like to express gratitude towards you all for the very effective aide I have been recieving and surprisingly quick responses to my posts. It has all bee helpful and I only wish there was some way for me to return the favor to you all...but I'm helpless so my advice will be worthless.

As for your sound suggestions, they seem to work quite well by comparison (though, 40 does lag a little, but easily fixed on my own)
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,979 Posts
Second of all, I would like to express gratitude towards you all for the very effective aide I have been recieving and surprisingly quick responses to my posts. It has all bee helpful and I only wish there was some way for me to return the favor to you all...but I'm helpless so my advice will be worthless.
it's ok, most of us don't have lives. and if we do....it's emuforums ;)
 
1 - 20 of 36 Posts
Top