Next Generation Emulation banner
1 - 4 of 4 Posts

· Registered
Joined
·
654 Posts
Discussion Starter · #1 · (Edited)
This is in ePSXe 1.60 with the NTSC version of Driver, NTSC BIOS, run via ePSXeCutor.

On attempting to do a replay or restart when Taking a Ride, I get an error dialog box that says, "Opcode 31 Unk". Exiting to the main menu works fine. Restart in Training or Undercover works fine.

I've tried several different SPUs, including turning sound off. No difference.
I've tried different settings and hacks in Pete's OpenGL GPU 2.7. Sometimes I get a hang instead of a crash&error dialog. Other than that, no difference.
I've tried one other GPU, the latest PeOps. No difference.
I tried both of Pete's DirectX GPUs. They just both crash.
I tried turning rumble off on the controller. No difference.
I tried several different CDROM drivers, including Mooby with an Alcohol-ripped image. No difference.

My workaround for now is to restart by exiting to the main menu. A save state might work as well, I'll try that too. Not having replays is irritating, though.

Has anyone else encountered this problem and found a solution? Does this problem not occur in another emulator?

Any help appreciated.


Dan

P.S. Works fine in my Playstation.
P.P.S. System specs:

Windows XP SP2
3GHz P4 HT, 800MHz FSB
2G mem
600G disk, about 360G used
ATI X850XT PCI-Ex graphics
C-Media EAX 2.0 compatible motherboard sound

All drivers up-to-date as of about a month ago.
 

· Registered
Joined
·
654 Posts
Discussion Starter · #4 ·
I haven't tried other emulators or other versions of ePSXe. So far I've managed to get 18 games (almost half my library) working well in ePSXe 1.60. I had hoped to get them all working in a single emulator.

I will try without ePSXeCutor, though that doesn't seem a likely problem source.

I'm not loading from save states. I wait 20 seconds for the logos to finish on each attempt.

It's just that OddbOd's ePSXe compatibility list has Driver at 100% perfect, so I was hoping someone on these forums had a "magic configuration" that would get past the problem.


Dan
 

· Registered
Joined
·
654 Posts
Discussion Starter · #8 ·
Much thanks, I appreciate what a PITA it can be to look up old threads.

Speculation time: I wonder if it's possible that there are some undocumented PSX processor instructions that ePSXe doesn't implement. Or does "Opcode XX Unk" refer to an unknown instruction for a specific coprocessor like the GPU or SPU?

Another possibility, I suppose, is that the game actually includes a bogus instruction, and the real PSX CPU treats unkown instructions as NOPs. If that's the case, it would sure be handy to have an option for ePSXe to make it do the same.


Dan
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top