Next Generation Emulation banner

1 - 2 of 2 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
This guide is based on my experiences with Linux Mint (based on Ubuntu). It should also work with Ubuntu and other Ubuntu-based Linux distros.

ePSXe on Linux is a far different beast than its Windows counterpart. For starters, there is not a hardware rendering plugin included. Also, there are 2 different versions to choose from: a 32-bit version and a 64-bit version. Both have pros and cons that I’ll go into more detail about later in the guide. Both versions can run on a 64-bit OS while a 32-bit OS is going to be limited to the 32-bit version. This guide is written assuming you are running a 64-bit OS.

System Requirements:
· OS: Ubuntu Linux (or a distro based on Ubuntu such as Linux Mint)
· A computer with a multi-core CPU
· Input: Keyboard or game controller (game controller recommended)
· GPU: An OpenGL capable GPU (Dedicated Nvidia GTX or AMD/ATI Radeon video card recommended)
· DVD drive for playing and/or ripping your PS1 game discs

Required Files:
· Latest version of ePSXe for Linux (32-bit or 64-bit)
· (Optional) a PS1 bios file
· (Optional) ePSXe Linux plugins (for 32-bit ePSXe only)
· Your game (original physical disc or the disc image files you ripped from it)

**Note** Memcard files and Savestates are interchangeable between Windows and Linux versions of ePSXe.

Getting Started:

64-bit: I’m going to cover the 64-bit version first because it is much more straightforward to get running for a beginner. Unfortunately, just downloading the 64-bit version’s zip file from ePSXe’s website didn’t work for me because of unmet dependencies on Linux Mint (your experience may vary), but fortunately there is a simple solution to get it working.

You need to go to this site: https://github.com/brandleesee/ePSXe64Ubuntu

Read the readme on the page, download the installer script, then run it. Brandleesee’s script here will fetch package dependencies and make launchers for you. It is basically as easy as installing a program in Windows (albeit in a command-line environment) which is the biggest pro to the getting the 64-bit version this way. It even includes some shaders, if you choose to install them, to enhance the visuals. The only major downside to the 64-bit version is that you are limited to the ePSXe Core plugins. You’ll need a decent multi-core CPU to run it at full speed, especially if you try to crank up the visuals on the software GPU Core plugin. The reason you can’t use other plugins is because all of the Linux ePSXe plugins are quite old and were only compiled for 32-bit systems. If you’re looking for accuracy, just leave everything at its default setting (except maybe adding scanlines) and enjoy the nostalgia.

32-bit: Installing 32-bit ePSXe on 64-bit Linux is significantly more time-consuming and difficult but, it has the huge benefit of being able to use hardware GPU plugins like Pete’s XGL2 and Tapeq’s Tweak to really enhance visuals if your graphics hardware is capable enough.

First, you’ll have to install the 32-bit libraries on your system. Open a Terminal and type:
Code:
sudo dpkg --add-architecture i386 && sudo apt-get update
sudo apt-get install ia32-libs
This will install a ton of 32-bit packages, but more importantly, the first command adds the 32-bit software repository. Now you can install any 32-bit packages you’ll need (and ePSXe needs quite a few.)

Next, you’ll need to download the 32-bit ePSXe Linux zip file from http://epsxe.com/download.php and unzip it. The first time you try to run it (nothing will happen because we haven’t installed the dependencies yet so it silently crashes, more on that later), it will create a hidden folder named “.epsxe” in your Home folder. Inside of that, it will create multiple folders similar to what come with the windows version (Config, Plugins, Memcards, etc.) and, if I remember correctly, it also copies the ePSXe executable here as well.

Now comes the time-consuming part: tracking down the individual dependencies.

Open a Terminal and navigate to “/home/(your username)/.epsxe” and type:
Code:
./epsxe
This should immediately try to launch the executable and should give you an error message in the terminal. The key to this is that it will tell you what file is missing in the format of “Failed to find shared library XXXXXX.so” (The X's will be the name of the particular missing file). Usually the name of that file coincides with the name of the package it belongs to but, Google the filename to be sure. You'll probably find the filename listed on an Ubuntu Launchpad page that will tell you what package it belongs to. Then, in a new terminal, type:
Code:
Sudo apt-get install (packagename):i386
where (packagename) is the name of the package you need. You’ll need to repeat this process several times until you manage to find all of the individual missing dependency packages and actually get ePSXe to run (when I get my desktop rebuilt, I’ll see if I can compile a list of what specific packages I needed to install to get it working...).

(Optional) In Linux Mint, I used the menu editor to add a shortcut to the menu. Just use the full path to the executable as the command to run. I also chose to check the option “Run in a terminal” so that I’d also have a terminal window open with ePSXe acting as a console that will show error messages and such.

(Optional) If you choose to download any outside plugins (such as Pete’s), you would need to put the file ending in .so.x.x (the x’s will indicate the version number if they are present) in the “plugins” folder (located in “/home/(your username)/.epsxe”) and the file ending in .cfg in the “cfg” folder (this folder might not be present. If not, create it). There may also be an executable included for the settings GUI, this goes in the “cfg” folder as well. After moving those files, the new plugins should then show up in ePSXe’s plugins list.

*IMPORTANT* Make sure to set CPU Overclocking to 1x the first time you run ePSXe! If you fail to do this, you will get a blank black screen when trying to load a game or ePSXe will crash altogether.

Configuration Tips:

See Outerbeast’s Windows guide: https://www.ngemu.com/threads/epsxe-basic-setup-guide-windows.204673/
Many of the config tips here are applicable to Linux also.

***A Note about Pete’s XGL2.9*** There is no longer a GUI to configure this plugin. The old GUI depended on GTK1.2 which is long since depreciated and is very difficult to track down (and not really worth it because the GUI is ugly and hard to read anyway). Changing settings is accomplished by manually editing the file “gpuPeteXGL2.cfg” in any text editor you prefer. It’s easier than it sounds because every setting is explained in pretty good detail inside the file. Any changes made while playing won’t take effect until the plugin is restarted (pressing esc while the game is running, then Run > Continue from ePSXe.)

I hope this guide is helpful for anyone trying to run ePSXe on Linux.

--------------------------------------------------------------------------------------------------------------------------------
Thanks to brandleesee for the awesome 64-bit install script on GitHub and also to Outerbeast because his great Windows guide inspired me to try and be helpful as well, plus I used the format of his guide as a template for this one.
 
1 - 2 of 2 Posts
Top