Next Generation Emulation banner
1 - 10 of 10 Posts

·
...
Joined
·
398 Posts
Well, 2.0.0 and 2.0.2-1 works fine in WinXP SP3 Pro.
I tested 2.0.5 and it certainly not works in my machine but doesn't crash ...I only have AMD CPU's (Celeron/Pentium III Slot 1 and PPC G3 don't count =P) in home. The next week, I test in my work with a "modern" Intel CPU too. My Phenom II doesn't support SSSE3/SSE4.x u.u

PS: Most likely not work anyway, even with POSReady. Bye bye XP.
 

·
Registered
Joined
·
2,171 Posts
Well, 2.0.0 and 2.0.2-1 works fine in WinXP SP3 Pro.
I tested 2.0.5 and it certainly not works in my machine but doesn't crash ...I only have AMD CPU's (Celeron/Pentium III Slot 1 and PPC G3 don't count =P) in home. The next week, I test in my work with a "modern" Intel CPU too. My Phenom II doesn't support SSSE3/SSE4.x u.u

PS: Most likely not work anyway, even with POSReady. Bye bye XP.
yes It was dropped in 2.0.0 but luckily for xp users still worked (I think there was a thread on here about it waaay back when 2.0.0 was released), enough extra has changed though now that it won't run...
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 · (Edited)
Hi, my fault, just because version 2.0.2-1 is working OK, i did not read the 2.0 readme to check the "vista+" announcement


Ok, I take a look at the executable, and found the problem is that 2.0.5 uses condition variables, that are not available in XP or lower



I modify epsxe 2.0.5, and make working in XP (32 and 64bits versions), i tested today and not problems (at least all games i tested work well)



here the download, is just the executable

http://akihabara-online.com/Main/Emula/epxse/ePSXe.zip



Will be easy to make working on XP again, a small change to code to just check windows version, and ignore or make a fake calls to this conditions if XP or lower


Greetings
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Well, that explains why the program doesn't return an error. Knowing this, is useless to test on other CPUs when the problem reside in the code in self.

Yes, just software stuff

If a epsxe dev read this, maybe can add some small code to avoid this condition variables, and make XP compatible again

for now, at least with my hack 2.0.5 is working good for me
 
1 - 10 of 10 Posts
Top