Next Generation Emulation banner
1 - 17 of 17 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
hi i have the latest DeSmuME v0.9.1 and i am not having any luck with it as of yet. every game i try to play is very slow, on avg less than 10fps, sometimes 10-20. Mario Kart DS and Super Mario 64 DS are two that run the worst. it takes nearly 5 minutes to even complete one race in MK, and SM64DS is nearly unplayable. i have tried all the frameskip options and no sound aswell, nothing seems to help. i dont think its my computer as it seems it should be powerful enough to play some of these. these are my specs:

Windows XP Professional SP3
Intel Pentium 4 HT 3EGHz 800FSB 1MB
3GB DDR PC3200 Crucial + Corsair XMS Double-Dual Channel
XFX Geforce 8600GT 512mb PCI-e x16
SoundMax Digital Audio
80GB 7200RPM HDD

thanks!
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
yea i tried the SSE2 exe, it does run better. and thnx for uppin the video! seems full speed and fully playable for u. what is the % in the title bar? is that the resourses that are being used? because urs was around 65% while mine are around 71-76%. i put it on frameskip 0 and it ran better, but its still not 100%, id say about 70% at best. ive tried turning the sound off aswell and it makes no difference with it on or off. plus, my music in MK plays very slow, it sounds almost depressing :(

thnx for the help.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #10 ·
its not HT causing it, i tried running the emu and set affinity to one thread, played exactly the same. i tried getting help from the maker of the emu but he accused me of using illegal backups and banned me from his forum. it seems that i wont be able to play NDS anytime soon as i dont have a dual core, just like PS2, GC, and Wii. i also tried iDeaS and it still perorms the same. o well, either im not configuring/tweaking something right or a P4 just isnt as powerful as a NDS..
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #12 ·
what is that? i ran the SSE2 exe and put it on frameskip 0, audio buffer 2500, and set affinity to one thread and New Super Mario Bros. runs better, but i still need to tweak it.

does anyone have xfire that wants to add me? faster i get replies the faster i get this down! if any of u can add me to xfire let me kno.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #16 ·
thanks for the suggestion Dax! it plays Mario 64 DS 100% for me, just a few questions tho. my sound is all crackly, is there a way to fix that? and also, is there a way to enlarge the screen or make it go fullscreen?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #18 ·
ok, do u have an Xfire so i can add u? or do u have msn or yahoo? if u dont want to add me thats fine, just u seem to kno what to do and i could use ur help! thnx for the help so far! i really appreciate it
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #22 ·
both iDeaS and DeSmuME run slow, unplayable. but this No$GBA runs perfect. the only problem is i cant figure out how to work any of the tools for it (Nds2x, NL4). and also my audio is crackly even when i change to mono.

u dont think the reason iDeaS and DeSmuME runs slow is my XP SP3 do u? i also have Windows 7 on here, but i havnt tried either of them on it yet. and Dax, check ur inbox!
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #24 ·
well i got some more info here. i loaded up MKDS in No$GBA and it acts really odd. at random points in the race it is perfect and smooth, but then right away it goes back to laggy. and in New Super Mario Bros, the menus are slow and so is the map, but when im playing it seems fine. i still have very crackly sound tho, cant seem to fix it :(

is there a way that anyone knows of to tweak No$GBA to stop lagging in MK? i downloaded myZoom and it has options to change the filters and speed, but nothing helps or hurts the framerate.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #28 ·
its funny that u say that shash, u didnt catch me doing sh!t. i wasnt using warez, but i couldnt explain that to u cuz u IP banned me before i could explain myself. i own those games, i just dont have the means to dump them, i dont have the flashcard or a mac. and btw, its not warez, idk where u live, but in the US it is legal to own a backup of any media if you own it, and even if you dont own it its legal to keep it on your computer for 24hrs before you have to delete it. you couldve been the bigger person by NOT banning me, especially when you dont have proof. i only downloaded those roms because i couldnt dump my own. but i still own them. its ok tho, i switched to a better emulator anyway. :)

schumi, yea ive figured that one out so far. i will be coming into some cash soon, so if i get enough i will be upgrading to a dual core, or possible a Phenom x3. thanks for the help. its nice to see people actually trying to help rather than ban you on your first post.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #30 ·
look, i am not on here to discuss ROMS and legalities of ROMS. please people, stop bashing me for this. you would be surprised how many people on this forum and many others actually are pirating these games. i came here to ask for help and discuss an emulator/s, not discuss a ROM/s. it is shash who started this, he couldve stayed out of this thread and the topic never wouldve even hinted at ROMS.

can we drop this? and actually discuss what i came here for? or shall i be banned for being pointed out, but any members here who actually pirated the roms and WERENT pointed out just get to discuss whatever they want freely?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #35 ·
im beginning to believe the reason i cant emulate DS very well through any emulator has something to do with the architecture of the Pentium 4. i believe this because i tried the same emulators on my other computer (Intel Celeron 2.20GHz 128kb L2, 640mb DDR PC3200, and a Geforce 6200 256mb) and it performed nearly the same as on my main computer (Intel Pentium 4 3.00GHz 1MB L2, 3GB DDR PC3200 Double Dual Channel, Geforce 8600GT 512mb). it seems odd dont it?

and shash, is there any way of removing that ban? i would like to be part of the forum again. and i dont think it was random, i think it happened because akismet thought i was trying to hack or something. you see, my ISP (HughesNet) forces EVERYTHING through a transparent proxy and that messes many things up, like i cant even download from FileFront at all.

edit: just for my privacy, could you blurr out my email address in that photo?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #39 ·
i could try that.. i dont know if it will work tho.

i thought about it overheating, but i doubt thats it. i play games that run my temp up to 80C and no throttle at all, no performance drop. i may just try disabling HT, but if it does help i likely wont keep it like that just for DS emulation. i play more PC games than i do emulated games. but i guess its worth a try just to see if thats what causes the slow downs.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #41 ·
i disabled HT throu the BIOS and il be damned if it aint fully playable. and this time i mean DeSmuME. only problem is my audio, its VERY slow now. i set it to frameskip 0 and the audio is on a buffer of 2500, but the game seems to play at normal speed, but the audio plays really slow.

shash, if u have msn or xfire and can add me let me kno, i think now that i have the emu running at speed we can figure this out.

p.s. thanks to you all for the help and ideas. :)
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #43 ·
most likely this is wrong, but its a shot in the dark.. maybe it has something to do with 8600s? we both have them and we both have poor performance.

and btw, i was a bit too over excited on my previous post, after running other games in the same emus, i got the same performance as i did with HT on. so it wasnt a HT problem.

and to the guy who has the 3000+, its no surprise that it runs these NDS emus! my gf has one and that thing is fast for an old cpu. its just odd that my P4 can wipe the floor with the 3000+ in some ares and yet epic fail at emulating NDS. one thing i noticed about all of the NDS emus is there are no CPU options, like Interpreter and Recompiler.. is that because of the ARM?
 
1 - 17 of 17 Posts
Top