Next Generation Emulation banner
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
MotionInJoy Vista x64 Rumble feature, with Epsxe 1.7

Hi I hope it's ok to add onto this thread and not create a new one since my problem seems to be similar aside from im using 64 bit vista and not 32.
I've searched using the search bar at the top for the past 3 days and can't seem to find an answer that best fits my problem. (If I missed it I'm sorry, half of this lingo is new to me)

But to the point! Im using Motionin joy usb driver for use of my Ps3 controller with epsxe. Fortunately (after many hours of tinkering with the motionjoy drivers, f8 bootup, DS3 tool, windows game controller program, and my trusty ps3 dualshock 3 controller) I have gotten everything but the rumble to work.

The ds3 tool has a rumble setting so I'm assuming it should work? correct me if my assumptions are wrong. Or maybe I'm using DS3 wrong?

I saw masta.g.86's configuration window and have my rumble settings mirrored on epsxe. I'd post a picture of my port1 controller config, but im not sure how.... :(

I hope someone can help me, if not, it's ok. I'm using espxe 1.7 if that helps and playing FFVIII. (I have vibration set to ON in the game, just in case it's not assumed) I'm running vista x64, on a Dell Inspiron, with Intel core2 duo inside. It's a 4 or 5 month old laptop.

Hope I listed enough information, and not all useless info!

Thank you!
-David
 

· Registered
Joined
·
2 Posts
I've been intending to write up a thread featuring the MotionInJoy drivers once I felt they had matured enough.

According to the website and readme file, you have to install the latest x64 driver (this driver has changed since my previous posts i.e. no longer blog 9) and then install the vibration update on top of that driver.

Select your gamepad profile and enable rumble and then click on 'Enable Option'. After that you can close the DS3tool window. For me, the program usually crashes on exit but does seem to save my selected options. Please note that most of the gamepad profiles don't work in the x64 driver.

View attachment 205408

Also, if you're actually using a Sixaxis gamepad, you will not get rumble under any circumstances. Ensure vibration is turned on in FF8 by pausing the game and turning on vibration.


It's a ps3 dualshock 3 with sixaxis, so I take it you mean just the regular sixaxis and not the dualshock will not have rumble. I'm going to try to find the vibration update now and see if it works.. My ds3 already says enable vibration but im going to cross my fingers and hope I am indeed missing an update.
Also from your picture should I also set it digital and not analog with my ps3 dualshock? or was it just an example for the vibration function box?

Thank you btw! I was expecting to get an answer a lot slower. I'll edit/update if this works :)


{EDIT} I got it to work, In case someone else comes along with the same problem I'll list what I did, or at least what I think I did and what you guys helped me with!

I downloaded the x64 vibration update at the Motioninjoy website(this is after I installed the motioninjoy x64 driver) and unziped it. I installed the update after it unzipped and then i noticed it said x86? x8somthing under the save in program files. I tried not to think much into it and installed it anyway(took like 2 seconds). I then went into the DS3 Tool that came with the motioninjoy driver, and I first clicked "Analog Gamepad2" and checked the vibration function, enable option. Well that didnt work, It wasn't until I clicked "Analog Gamepad 3 with added motion sensor" That it worked in FFVIII, go figure.

Now for the options on Epsxe, config>gamepad>port1>pad1> My configuration was the same as Masta.g.86., Dualshock [f5], type:dxjoy1, bigmotor:constant, small motor:sine. click ok, play your game and everything should be fine as it was for me(its a load of bs but itl give you some hope, so many things can go wrong. specially if your like me and new to this)

The hardest part is in the beginning getting the dualshock to work with 64x. My biggest problem was remembering to restart the computer with f5 and disabling driver protection. remembering to press the middle PS3 button a couple dozen times to get it to turn on, went over my head more than once.

hope this helps someone

Thank you Masta.g.86! I would have never known there was a seperate update for vibration!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top