Next Generation Emulation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,535 Posts
Discussion Starter #1
Welp, I never really played anything doom related so this is a first for me. plus im really late to the release of this game, i got HL2 first :). id say this is one of the most freakiest games iv ever played :???: it has some real WTF moments so far, maybe its just me since i never played the first two. but anyway hear i go

Graphics : Reaaaly nice :thumb: my only regret is i couldnt turn the graphics all the way up in the settings, i tried. and it keept freezin and crashin on me. i dont think doom 3's system agrees with my ATi Card. btw, i love how they did the Controll Pannels interactive . the PDA kindof annoy's me though, Along with the weapon textures. the pistol looks.... blocky to say the least. hope all the weapons wont look like that. Some of the Zombie textures iv seen so far also give that "blocky" feeling, i think they mainly focused on enviroment textures rather than everything else.. and another thing, iv noticed that sometimes after i exit this game my system kindof slows down. :(

Sound : CREEPY... Damn, again. some wtf moments for a doom newbie, but i like it :thumb:

Gameplay : sofar its rather easy... maybe its just a zombie thing. /me needs a gamepad

Over-all raiting : 9/10 since im a doom newbie :D
 

·
Premium Member
Joined
·
21,977 Posts
800x600 eh? that's what i beat the entire game at back on my 5600. but yours looks a hell of a lot better than mine ever did.

i think Doom3 was a much better game than HL2, for many reasons.

just keep playing this one, the best is yet to come ;)
 

·
!!!METAL UNCLE!!!
Joined
·
1,951 Posts
Its recommended to get Ultimate Doom 3 tweaker by Rippo, and run it. It optimises your game fitting to your system. For example, Doom3 shaders are optimised to Nvidia cards, but with this one you can turn them to ATI friendly, and therefore bumping up the speed.
 

·
Registered
Joined
·
2,535 Posts
Discussion Starter #4 (Edited)
hushypushy said:
800x600 eh? that's what i beat the entire game at back on my 5600. but yours looks a hell of a lot better than mine ever did.

i think Doom3 was a much better game than HL2, for many reasons.

just keep playing this one, the best is yet to come ;)
Yeah the game HATED my system with a pure passion when i ran it at 1024x768 with "ultimate" graphic settings, it was so slow. laggy, and it forze acouple times. oO thats why i was stuck at 800x600.
 

·
Premium Member
Joined
·
6,341 Posts
When I tried the Ultra mode at 1024x768 on my 9500 Pro, it ran about the same speed as High unless I was moving around in a big area or if I was walking from room to room, in which case it would pause for a second or so (major texture swapping over the AGP bus :p). Heck it does that a little bit even on my new card. The two modes look pretty much identical though, so I use High instead.
 

·
Registered
Joined
·
2,535 Posts
Discussion Starter #7
n_w95482 said:
When I tried the Ultra mode at 1024x768 on my 9500 Pro, it ran about the same speed as High unless I was moving around in a big area or if I was walking from room to room, in which case it would pause for a second or so (major texture swapping over the AGP bus :p). Heck it does that a little bit even on my new card. The two modes look pretty much identical though, so I use High instead.
yeah i noticed that, Ultra was doing the same thing with me. i cant have AA on either, guse this game hates my ATi card or something
 

·
Premium Member
Joined
·
6,341 Posts
I didn't dare try using AA/AF with Doom 3 with the 9500 Pro; running at a decent rate at 1024x768, High was good enough for me :p. I've noticed that with my new card if I use the control panel AA settings there's no speed loss but if I use the game's internal settings, the framerate drops like a rock (25 FPS loss @ 2x, 60 FPS loss @ 16x) oO.
 

·
!!!METAL UNCLE!!!
Joined
·
1,951 Posts
guse this game hates my ATi card or something
And i said there is a fix for this, either thru ultimate game tweaker or separate fix file (which i forgot where to get...)

Ultramode isnt that much better looking compared to High. It just increases the size of textures, and therefore going slower in hectic places. Detail between them isnt groundbreaking.
 

·
Registered
Joined
·
2,535 Posts
Discussion Starter #10
hmm. just noticed something, cant seem to activate the surround sound speaker setting through doom 3, it wont pick up any 3d audio. oO
 

·
Registered
Joined
·
496 Posts
You have to set up your soundcard for 5.1 surround to get it to work. The game refuses to let surround be enabled if you're using 7.1, unfortunatley, so you're forced to set it to 5.1.
 

·
Premium Member
Joined
·
21,977 Posts
also, when i first started playing, the sound would die out a lot. like, it was hella intermittent. i have a feeling thats with a certain set of drivers i was using, though, becuase it happens occasionally in video files for me too.
 
1 - 12 of 12 Posts
Top