Next Generation Emulation banner
1 - 20 of 22 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
When i try to play Super Mario Sunshine on Dolphin Emulator, a warning window shows up and says:

"Can't Create an Opengl renderer. You might be missing an opengl extention, check the log for more info" :mad:

SO, i did check the log(which i dont understand):

25:57:788 N[BOOT]: Loading Settings from ./User/Config/Dolphin.ini
25:57:937 N[BOOT]: Starting application
25:58:006 N[BOOT]: Loading Settings from ./User/Config/Dolphin.ini
25:58:063 W[COMMON]: IsDirectory: stat failed on ./USER/WII/TITLE/00000001/00000002/CONTENT: The system cannot find the path specified.

:pCmad:

I've been trying to mess with it and nothing seems to work, maybe a program or a missing extention i need...

COMP INFO:
Processer: Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz 2.00GHz
Driver Version:6.0.6001.18000
Graphic Card: (will be updated) or whatever comes with a [Dell Ispiron 1525]

Any other info u need, post it...

NOTE:I don't know much about computers, so plz me specific
 

·
Spriggan
Joined
·
443 Posts
When i try to play Super Mario Sunshine on Dolphin Emulator, a warning window shows up and says:

"Can't Create an Opengl renderer. You might be missing an opengl extention, check the log for more info" :mad:
I get the same error! :rolleyes:

Doesn't matter what game I try :dead:

To fix it I either have to enable or disable Dual Core.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 · (Edited)
When i use the D3D9 plugin, the games almost starts(this is with HLE plugin) the window comes up, then error and doplhin stops working, D3D9 with LLE plugin brings up the window, at the top where the name of the window will say loading(+from twhere the game is in my computer) ill get some pics of the windows

I get the same error! :rolleyes:

Doesn't matter what game I try :dead:

To fix it I either have to enable or disable Dual Core.
It doesnt matter if i have dual core mode on or off...

Driver Version Now: 7.14.10.1409
 

·
Premium Member
Joined
·
5,934 Posts
You need to use an older build with the older DX9 plugin, DirectX is borked in the newest revisions.

With how buggy the DX9 plugin is considering it contains many graphical issues that have been fixed in the OpenGL plugin and the fact you might get shoddy performance, it may be better if you stuck to playing on an actual Gamecube/Wii for the time being.
 

·
Registered
Joined
·
2,614 Posts
Yes, play them in your Wii or GC until the DX9 plugin is fixed. :(
 

·
Registered
Joined
·
7 Posts
Please help...

Okay I have been back and forth from site to site and I cannot figure this out… I have had problem after problem and will admit I’m a noob with a p.o.s. computer but I had my x-box 360 stolen and I am just trying to get to same games… I have a gamecube but it’s in storage and I can’t get to it right now so I tried to download an emulator… I got dolphin a while ago and gave up on it but now I’m home alone and board out of my skull so I tried to get back to it I got around the 1 gig continuous memory deal and found ample help for doing so but now I get new error messages I was going to take screen shots but I don’t feel like uploading them to a site so here is the deal… (p.s. I know this info is somewhere but I can’t find it sorry)

My first copy of dolphin is svn r3661 or whatever and I attempt to open Mario sunshine and receive the message “Error Loading Plugins/plugin_dsp_hle.dll” (followed by 2 other messages) well okay now I will look that up because that is new since I installed Dolphin JITIL x64 Revision 4586 … I believe my computer is 32 bit though… and that I believe is for 64 IDK anyhow I d/led it and it said that it wasn’t a valid win32 app or something which I figured was the case so I figured that maybe swapping some files or something might help and get it to where it needed to be but I don’t know the differences for all the programming so ehh anyhow I moved the first copies exe file over to the seconds folder and now if I click it in either folder I get that message… so as I said I’ll look it up… I am just keeping this log so people know where I’ve been / what I’ve done… p.s. thanks Xtreme2damax for your signature as well as pointing it out to us noobs :p … (and I hade opengl probs… till I got to http://forums.ngemu.com/dolphin-discussion/111777-opengl-plugin-missing.html) Several Forum threads later (including other sites) … too much confusion of different topics gets clustered  and sites like Issues - dolphin-emu - Project Hosting on Google Code
Annoyance leads me to search for the newest version available for 32 bit & compiling understanding…
Dolphin - Windows Live
I downloaded Dolphin-r4595.7
And once more back to the ogl… with
Cannot create open gl render… might be missing extensions, check logs blah blah
Logs 18:31:250 N[BOOT]: Loading Settings from ./User/Config/Dolphin.ini
18:31:875 N[BOOT]: Starting application
18:32:000 N[BOOT]: Loading Settings from ./User/Config/Dolphin.ini
18:32:156 W[COMMON]: IsDirectory: stat failed on ./User/Wii/title/00000001/00000002/content: The system cannot find the path specified.

18:53:421 N[BOOT]: Saving Settings to ./User/Config/Dolphin.ini
18:56:671 W[EXI]: No memory card found. Will create new.
18:56:718 W[EXI]: No memory card found. Will create new.
18:57:765 N[BOOT]: Booting C:\Documents and Settings\RED II\My Documents\Downloads\Games\Emulators & roms\GC & Wii\Super Mario Sunshine (USA) RARE/sms.gcm
18:57:796 N[FileMon]: Opening 'C:\Documents and Settings\RED II\My Documents\Downloads\Games\Emulators & roms\GC & Wii\Super Mario Sunshine (USA) RARE/sms.gcm'
18:57:968 N[OSREPORT]: 81200308->81300000| Apploader Initialized. $Revision: 29 $.
18:57:968 N[OSREPORT]: 81200324->81300000| This Apploader built Apr 10 2002 02:35:29
18:58:390 E[Video]: *********
GPU: ERROR: Need GL_EXT_framebufer_object for multiple render targets
GPU: *********Does your video card support OpenGL 2.x?
18:58:390 E[*]: Warning: Can't create opengl renderer. You might be missing some required opengl extensions, check the logs for more info
19:50:859 W[CONSOLE]: Stop [Main Thread] ---- Shutting down ----
19:50:859 W[CONSOLE]: Stop [Main Thread 1780] 243,384 K Stop CPU

Now on to see if my video card supports it / find the gl_framebuffer…
No locating file through a search and many forums of no help 
… did I d/l wrong version for my comp again hmm…?
(what does the r & mm mean?)
Don’t understand half of plugin configs 
Also running to other places of this forum like
http://forums.ngemu.com/ps2-plugin-...eshooting/97535-question-before-question.html
has just lead me to believe I can’t do it on this comp… I know it’s a p.o.s. with integrated onboard whatever b.s. (The only good thing about my comp is my terabit external hard drive… which is well easily moved to another comp when I have $$) but I figure that there must be loop holes… I had problems playing other games like wow and stuff & I resolved it with riva tuner well a friend did but I have moved and had to reformat so now I have the prog again but dunno how to use it… please guys there must be some way to play it on here… I’m broke without a job and no money for a new graphics card… not like one would fit in my housing case anyhow … I’ve tried and have a few from past attempts but it’s too narrow… there are two more comps in the house one in which is even older and a newer laptop but they are not mine and try not to use them at all costs… Well I guess I’m at a lose and just going to post this to see if any help is available… this is my first post and I dunno how it contacts me and lets me know about replies… but I’ll bookmark it and if available please IM me via [email protected] comp details… (and if I disable dual core it says no possible memory base found…)
------------------
System Information
------------------
Time of this report: 11/21/2009, 00:07:44
Machine name: REDII
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_rtm.040803-2158)
Language: English (Regional Setting: English)
System Manufacturer: Dell Computer Corporation
System Model: OptiPlex GX270
BIOS: Phoenix ROM BIOS PLUS Version 1.10 A06
Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz
Memory: 1014MB RAM
Page File: 604MB used, 1841MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: Intel(R) 82865G Graphics Controller
Manufacturer: Intel Corporation
Chip type: Intel(R) 82865G Graphics Controller
DAC type: Internal
Device Key: Enum\PCI\VEN_8086&DEV_2572&SUBSYS_01511028&REV_02
Display Memory: 96.0 MB
Current Mode: 1280 x 1024 (32 bit) (60Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: ialmrnt5.dll
Driver Version: 6.14.0010.4396 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 9/20/2005 12:52:38, 36990 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ialmnt5.sys
Mini VDD Date: 9/20/2005 13:00:54, 1302332 bytes
Device Identifier: {D7B78E66-6632-11CF-B462-5B21A3C2CB35}
Vendor ID: 0x8086
Device ID: 0x2572
SubSys ID: 0x01511028
Revision ID: 0x0002
Revision ID: 0x0002
Video Accel:
Deinterlace Caps: n/a
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Not Available
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

Found a site (KluDX - DirectX and OpenGL capabilities of Intel(R) 82865G Graphics Controller video card) and it simply states that what I need is not supported … so I am on to figure out if a loop-hole does exist…
 

·
Registered
Joined
·
7 Posts
I have upgraded to sp3 I dunno what all it changes but ehh… (well I’m doing so now..) & I was wondering if I made any of these changes if it would help… Graphics - OpenGL* Settings Guide Main concern now though is if riva tuner or any other progs of the sort would force / trick this into working… Downloaded opengl extension view and checked for updates for bs… no change…
After Sp3 upgrade new error : No possible memory base pointer found!
Following input found on Issue 1624 - dolphin-emu - No possible memory base pointer found error - Project Hosting on Google Code
“Just as a double check I ran back on all builds. Commit 4505 is the problem. 4504
works just fine but 4505 starts the memory problem. ”

“E2180 @2.00Ghz , GeForce 8500 GT (nvidia says I have 190.89 drivers) , WinXP x86 ,
2GB ram ( and NOD32 )

It only happens with D3Dplugin + GC games ( or at least I don't have it in SSBB )”

“WORKAROUND(?):
I've found that deleting my Dolphin.ini file (in .\user\config\) will let the game
load again. Obviously this means losing all your settings every time though...”

That was stated to only work for wii by one member and then another said it worked for gc for them…

And more or less same post at this site with
http://forums.ngemu.com/dolphin-dis...le-memory-base-pointer-found.html#post1760670
(I know some of this is redundant but I don’t want people to think I didn’t try searching it first.)

So I deleted the dolphin file in the config folder…
& of course returned to the “Warning: Can't create opengl renderer. You might be missing some required opengl extensions, check the logs for more info”
Well it’s been just shy of 7 continuous hours for me on this and I doubt I’ll find a way around my p.o.s. graphics card so I’m out for now… but if anyone does have anything to add please do…
 

·
Registered
Joined
·
2,614 Posts
Download the OpenGL Viewer (or something like that). If your graphics card does not support OpenGL 2.1 (or more), then, forget using OpenGL plugin. ;)
Pd: Next time, don't bump threads or doublepost! Use the button of "EDIT" if you want to edit the post! xD
 

·
Time Lord
Joined
·
1,989 Posts
wow, at least this time i didnt have to say "post more details". , Re-download Dolphin, making sure you get the win32 version, update your directx and use direct3d plugin
 

·
Registered
Joined
·
7 Posts
Thanks...

I really want to get it to work but I don't think it will I just don't have the Opengl 2.0 and I already updated direct x I mean I might have the wrong version of the emu but even if I did that and checked on those updates (which I believe I already have) I don't think it'll solve the problem :( I guess I'll try it anyhow though but I don't know where / what the most up to date version for 32 is... does the Dolphin JITIL x86 SVN Revision 4597 work for 32? I dunno what the 86 is for...

And what does the "r" stand for ...? revision?
I have DirectX End-User Runtime Web Installer deal up to date but ... what is it that I need for this game? I see that direct x is now up on 11 but I don't think I can get that for this ... I was wondering if their is a specific thing I am suppose to click to get all the direct x up to date or if I have to go through and click on separate links or IDK I just figure the web installer is a different thing then what I need...

Okay anyhow I got 4605 version and went to graphics and put it on what you said and it loaded with a message saying "Warning: FBManager::Create FAIL: Depth Color Texture" and then I closed that window screen was black but I heard the game music and other sounds... THANK YOU!!! you have gotten me a step farther now I'm going to research that and delete the other 3 versions I have once I get it to work

If I run it without the cpu->efb enabled then the message doesn't show but same effect and if I use the dolphin software renderer it blanks out the screen in yellow
 

·
Registered
Joined
·
7 Posts
Alright thanks and uhm yeah that's what I got... and I just finished d/ling 2 more games and tried them out... first one didn't d/l right and the second one prompted me with a message reading "Warning: Your GCM/ISO file seems to be invalid, or not a GC/Wii ISO." So I haven't gotten any further :(
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top