Next Generation Emulation banner

1 - 11 of 11 Posts

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Discussion Starter #1
Just as I thought everything was perfect with my PC and I could finally get down to some real gaming, a new problem pops up. DirectX 10 won't work for Far Cry 2 (game simply crashes to desktop instantly after launching) and in Assasin's Creed it looks as if I am applying some sort of emboss effect to everything. DX9 for both games works A-Ok though.
Perhaps I should take some screens of Assasins Creed later if you don't understand what I mean, but almost everything is black, for instance when I played the Tutotorial Altair was all black with with everything else being different shades of gray sort of, the crowds I had to shuffle past in the tutorial were black with their bowls and things they were carrying showing in a silvery golden texture. It basically looks like a Black and white world with only certain people and items appearing in colour. During the first mission it's basically the same but the 2 fellow guild members looked as they should (although they had cracks of black in them). It basically looked like a 3D plugin for an emu which barely started working.

Now, I made this thread in the hardware section hoping it's a software fault.
Far Cry 2 is still the Original retail version, Assassins Creed is the 1.02 version, I am using the 180.84 beta drivers for GTA4 (gonna wait for december drivers before I start thinking about hardware fault) and obviously Vista Home Premium SP1 (fully up to date) 64bit edition. I have also tried to the Bioshock Black Screen fix of disabling tablet features but that has not helped.

So has anyone experienced anything similar? Does anyone have a solution for me? Do you think it's a software fault? Do you think my graphics card is defective?

I am going to have to wait a week or 2 till I can talk to the PC shop that assembled my PC for me incase the card might be defective.

Thanks for any and all help you can give me.
 

·
Banned
Joined
·
23,263 Posts
Obviously you've updated with the latest DirectX Bimonthly.

So otherwise, i'd try installing MSVC 2008 SP1 redist (2005 redists are installed with .net)
The latest Application compatibility toolkit.


However, it sounds like a Driver issue, force all settings to off and try there.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Discussion Starter #3
Yeah I forgot to mention that, DirectX is fully up to date which I updated with the webinstaller though, perhaps I should get a propper redist...but I can't seem to tell what's for DX9 and what's for DX10.

I shall look for MSVC 2008 SP1 redist and install it.

What do you mean by set everything to off? in the game? in the nVidia control panel? using some other app?
 

·
Banned
Joined
·
23,263 Posts
well i'd figure i mean the NVCP since i mentioned driver :p
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Discussion Starter #5
Yes, but you have often mentioned nHancer and other apps to me as well.
 

·
Banned
Joined
·
23,263 Posts
Nhancer > NVCP for quality configs.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Discussion Starter #7
Hmm well I turned everything off (including PhysX) but without restarting and no change in Assassins Creed.
 

·
Banned
Joined
·
23,263 Posts
In that case, i recommend a clean install of the drivers (Safe mode install xD)

if it still doesn't work its probably a driver bug.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Discussion Starter #9
What do you suggest I use to clean the drivers?
 

·
Banned
Joined
·
23,263 Posts
Just remove it in safe mode, the uninstaller does practically all the work these days. Driver cleaners are only worthwhile when the uninstall fails.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Discussion Starter #11 (Edited)
Ah ok. Will do that a little later. Thanks.

Edit: BINGO it worked, thanks. I guess either they did not install correctly before...or in their eagerness to fix GTA4 they were broken in 180.84 as I am now using 180.48 the official November drivers again.
 
1 - 11 of 11 Posts
Top