Next Generation Emulation banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Guys,

My apologies if this is in the wrong place is my set up may be wrong (haven't tried other games).

To start off I'd like to admit I'm new to ePSXe (as in this is my first time using it). Despite this I'm not too shabby using computers and am able to do most things required to be considered 'good'.

I set up my ePSXe fine, I'm using Pete's OpenGL 2 driver which should run fine on my Nvidia 9800GT graphics card. My other computer specs are a AMD Phenom II dual core 3 GHx, 4GB RAM (actually just over 3GHx because I'm using 32bit XP)...

Anyway I decided recently dust of my playstation one and play some of my old games. A good favourite of mine (along with FF9) was always Digimon World 1.... After spending a good hour looking for it I had to give up! After a while I thought I'd look to see if I could get it 'illegitimately' and found that downloading Roms is actually legal if you own the game. Good news for me so I downloaded Digimon world 1 + ePSXe.

Ok the problem I get is that when I load up the game it starts up fine with the intro movie thing starting without a hitch. But when I choose to skip this intro it just stops... The screen stays black and ePSXe acts as if it has crashed/froze up. I've left it a while with no luck and the only 2 things I can do is to close it or hit escape to bring up the main screen again...

Also like to add I have tried a few different bios'...

I would appreciate any help where possible :)
 

·
Banned
Joined
·
23,263 Posts
Rip to CCD/MDF with subchannel reads enabled.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for your fast request Squall... I have Alcohol 120% and was able to convert it to a mdf file...

Tried it with that and it didn't even load up the intro movie!

I also noticed that my original version was actually a ccd one (CCD/IMG/SUB)

Despite this I tried converting it again via Alcohol and got the same problem after the intro movie...

Any other ideas? Maybe I've downloaded a duff copy and should look for another? It's a shame I didn't have my CD (although to be honest if I did I'd be playing it on my Playstation)...
 

·
Banned
Joined
·
23,263 Posts
Downloaded illegally shared games are not supported here... and yes it is likely the copy is bad. I've seen FF7 and 8 rips have similar issues even though they were in the correct format... the likely scenario is that it was formerly in the ISO format but someone decided to reconvert, and since the ISO format is already a lossy format for PSX titles then the CCD doesn't work properly.
 

·
Tyrant
Joined
·
555 Posts
AFAIK none of the Digimon World games contains any subchannel data, as can be seen here.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
indeed, usually PAL versions make use of the subchannel data as a part of the copy protection method. if it isnt there, the game will not start.

NTSC users might be able to get away with using a format like .bin/.cue or even .iso in some cases, but anyone playing a PAL version must use a format that includes all of the subchannel data.
 

·
Tyrant
Joined
·
555 Posts
...and this protection type is called LibCrypt.
I am not a total noob regarding this, really.
Especially when there is a brilliant explanation at the site I pointed to earlier.
Unfortunately is psxplist no more, where all protected games and the type of protection were listed.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top