Next Generation Emulation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Greetings! Newcomer here, and I'd like to ask for some help concerning running Diablo 1 on ePSXe.

I've tried two ISOs and encountered the same issue; I am able to get to the title screen, make a character and everything, but once I get into the main game itself the character won't move at all. I can turn it to face different directions but it can't walk at all. Anyone else encountered this issue? Thanks in advance to anyone who might have an idea.
 

·
Not a Registered User
Joined
·
1,325 Posts
Care to post the settings you used, more precisely gamepad settings and what are you using, keyboard, gamepad.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Care to post the settings you used, more precisely gamepad settings and what are you using, keyboard, gamepad.
I'm using keyboard. Settings are for SCPH-1080 Digital controller. Attaching screenshot...



As for other settings (if it helps), I've set CPU overclocking to 1x, CPU Mode to Interpreter, Pete's OpenGL2 GPU core 2.0.0. for graphics (Windowed mode, 1280 x 1024)
201616
 

·
Not a Registered User
Joined
·
1,325 Posts
I'm using keyboard. Settings are for SCPH-1080 Digital controller. Attaching screenshot...



As for other settings (if it helps), I've set CPU overclocking to 1x, CPU Mode to Interpreter, Pete's OpenGL2 GPU core 2.0.0. for graphics (Windowed mode, 1280 x 1024) View attachment 201616
Ok what version of ePSXe you're using and what BIOS file you're using lastly what version of Diablo you're running PAL/NTSC? Also make sure that HLE is disabled in BIOS settings.
Try setting the CPU mode to DYNAREC, it's much faster than interpreter and the difference is nonexistent at this point.

I tried your settings to no success to replicate this issue, thou when I tried interpreter I got black screen during the FMV and it frezzes.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Ok what version of ePSXe you're using and what BIOS file you're using lastly what version of Diablo you're running PAL/NTSC? Also make sure that HLE is disabled in BIOS settings.
Try setting the CPU mode to DYNAREC, it's much faster than interpreter and the difference is nonexistent at this point.

I tried your settings to no success to replicate this issue, thou when I tried interpreter I got black screen during the FMV and it frezzes.
2.0.5, SCPH1001.bin is the BIOS I'm using.

So changing the CPU mode to Dynarec seems to have fixed the issue! I had it switched to Interpreter because some games (like Einhander) would run way too fast with Dynarec. I guess I have to fiddle with settings for each game. Only thing I noticed is that it takes forever to save/load the game.
 
1 - 5 of 5 Posts
Top