Next Generation Emulation banner
1 - 5 of 5 Posts

· Registered
Joined
·
831 Posts
1. Selecting roms from recent roms list is broken.
2. Autodetect does not work on EEProm64K (512kb) (Naruto Path of the ninja DS) Crash error occurs. (workaround- by placing a dummy 64KB file with the same name)
3. Missing Basic Wifi support prevents Pokemon Diamond/Pearl from getting ingame.
4. Megaman ZX Advent - Gets ingame, but Megaman, NPC's and animated objects not visible (Layer missing)
5. LoZ - Phantom Hourglass, fails to boot (U).
6. Auto frameskip is a little overactive, causing jumping and skipping where not needed.
I've just tested the version 0.9.1 :

1. The recent roms menu works perfectly for me.
2. You tested one single game. Test other games and see. Normally autodetect works correctly, but with some games it doesn't. And does this bug happen on 0.9 ?
3. The wifi system is completely broken. Even if you download the source and compile it with the EXPERIMENTAL_WIFI define (required to enable wifi), Pokemon surely won't be playable.
4. Does this bug happen on 0.9 ?
5. These games aren't in the compatibility list. Are they compatible with 0.9 ?
6. Are you under Linux or whatever ? In the Win32 port the auto frameskip works correctly.
 

· Registered
Joined
·
831 Posts
1. The recent roms menu works perfectly for me.
Select a game in the list., works in 0.9, fails in 0.9.1.

2. You tested one single game. Test other games and see. Normally autodetect works correctly, but with some games it doesn't. And does this bug happen on 0.9 ?
I tested 19 games, only 4 had issues. Pretty good considering the other emulators had issues with half the games.

3. The wifi system is completely broken. Even if you download the source and compile it with the EXPERIMENTAL_WIFI define (required to enable wifi), Pokemon surely won't be playable.

Complete wifi isn't required, all that is required is the hardware responds appropriately to a write to the wifi init register. As far as i've read on the subject the game does something similar to the Zelda oracle games, except instead of a write to an audio register it writes to the wifi register, then reads it back, if the value is wrong or non existant the game fails to continue past that point.

4. Does this bug happen on 0.9 ?
Yes, layer is missing.

5. These games aren't in the compatibility list. Are they compatible with 0.9?
Compatibility lists are for the pawns who only want to play the emulator without contributing bugs towards its development. USA fails to boot in 0.9, but Euro boots fine

6. Are you under Linux or whatever ? In the Win32 port the auto frameskip works correctly.
No, it doesn't work fine, the Frameskipping is sacrificing smoothness for speed that it doesn't really require, a frame skipping of 1 is enough to get most games running smoothly, however the auto option seems to use 5+.
1. I already said, I can perfectly open a ROM from the recent roms menu.

2. Hmm... good. But, for the games that have issues, do they have the same issues on 0.9 ?

3. Hmm... I'll look at that issue.

4. So it isn't a regression. In your "DeSmuME 0.9.1 Bugs" thread, it sounds like the bug appeared in 0.9.1 .

5. USA and EUR versions of the same game may be different. See SM64DS, for example, the first version contains lots of glitches that the other versions don't have (including EUR).

6. I asked you if you were using Linux or whatever that's not Windows.

BTW, I tkink we should have a nice "DeSmuME 0.9.1 released" thread, instead of this bug thread which makes DeSmuME 0.9.1 look super-buggy.
 

· Registered
Joined
·
831 Posts
Hmm... okay, but this thread still makes DeSmuME 0.9.1 look super-buggy, as we never got this type of thread before, and also Squall-Leonhart who reports these bugs sounds to me like they don't happen on 0.9 and they're regressions.
 

· Registered
Joined
·
831 Posts
if you know where I can get an original (definitely unpatched) rom please DO NOT pm me and I will NOT try it out.
Merlisch: shashClp is right. You sound like were asking for a ROM (against the rules!), and you just put a DO NOT and a NOT. See, I can do it too. It is NOT intelligent, DO NOT do it please.

EDIT: oops, I'm a bit late I guess. Sorry x_x
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top