Next Generation Emulation banner
1 - 14 of 14 Posts

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #1 · (Edited)
Report your bugs here.

1. 0.9.1 - Zipped roms not loading from recent roms list.
2. Autodetect does not work on EEProm64K (512kb) (Naruto Path of the ninja DS) Crash error occurs. (workaround- by placing a dummy 64KB file with the same name)
3. Missing Basic Wifi support prevents Pokemon Diamond/Pearl from getting ingame.
4. Megaman ZX Advent - Gets ingame, but Megaman, NPC's and animated objects not visible (Layer missing)
5. LoZ - Phantom Hourglass, fails to boot (U).
6. Auto frameskip is a little overactive, causing jumping and skipping where not needed.



You can log bugs @ Bug Tracker
Otherwise, Post them here, and I will check them out, and log them if reproducible.
Be Clear on the Rom Revision, and Regioning.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #3 ·
Placing a dummy 64KB file in the folder allowed me to save xD.

may i suggest configurable states and battery folders? i prefer not to mess the Rom directory up with save information.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #7 ·
Steady on Shashclp, keep this thread open anyway. If anyone reports a bug here, i'll test it myself and log it if its reproducible.

Sourceforge's site is a performance ***** for most people anyway. so i can understand why people avoid it.

btw, https://sourceforge.net/tracker2/?func=detail&aid=2217330&group_id=164579&atid=832291 < unless 1436 is newer then 0.9.1, its not fixed. the Eur rom is not affected.

unless of course your USA rom happens to be different to the one i have (my USA dump is 64MB, while the Eur dump is 128MB)
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #9 ·
DON'T REPORT YOUR BUGS HERE!

We have a better way to do so:

Bug Tracker

Then click "Add artifact". Posting here will probably not be seen by most of the developers, if seen at all :p

Also, on a non relate note, I booted and got ingame on both Zelda:pH and Pokemon with a SVN build I did, so I don't really know what broke on 0.9.1 :p

didn't see your ninja edit (or atleast the bottom of this post haha.)

Yeah, same goes for the Recent Roms list, it worked in 0.9 but not in 0.9.1

I also noticed the SSE_2 build of 0.9 would launch on my AXP, but the 0.9.1 build doesn't (not a bug, obviously)
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #11 ·
lol, yeah, seems like one of those obscure things, since the Euro rom works.

good thing it can load the USA save :p
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #13 ·
1. The recent roms menu works perfectly for me.
Select a game in the list., works in 0.9, fails in 0.9.1.

2. You tested one single game. Test other games and see. Normally autodetect works correctly, but with some games it doesn't. And does this bug happen on 0.9 ?
I tested 19 games, only 4 had issues. Pretty good considering the other emulators had issues with half the games.

3. The wifi system is completely broken. Even if you download the source and compile it with the EXPERIMENTAL_WIFI define (required to enable wifi), Pokemon surely won't be playable.

Complete wifi isn't required, all that is required is the hardware responds appropriately to a write to the wifi init register. As far as i've read on the subject the game does something similar to the Zelda oracle games, except instead of a write to an audio register it writes to the wifi register, then reads it back, if the value is wrong or non existant the game fails to continue past that point.

4. Does this bug happen on 0.9 ?
Yes, layer is missing.

5. These games aren't in the compatibility list. Are they compatible with 0.9?
Compatibility lists are for the pawns who only want to play the emulator without contributing bugs towards its development. USA fails to boot in 0.9, but Euro boots fine

6. Are you under Linux or whatever ? In the Win32 port the auto frameskip works correctly.
No, it doesn't work fine, the Frameskipping is sacrificing smoothness for speed that it doesn't really require, a frame skipping of 1 is enough to get most games running smoothly, however the auto option seems to use 5+.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #20 · (Edited)
Hmm... okay, but this thread still makes DeSmuME 0.9.1 look super-buggy, as we never got this type of thread before, and also Squall-Leonhart who reports these bugs sounds to me like they don't happen on 0.9 and they're regressions.

Bug 1 needed further consistency testing, found the culprit and created a new bug with the correct information, and marked the old bug as invalid.

The issue is caused by zipped roms. 0.9 loaded zipped roms from the recent list just fine, but 0.9.1 fails to load them.

Also had it validated by Kaizen/John Aiton on both the builds.

Hmm... okay, but this thread still makes DeSmuME 0.9.1 look super-buggy, as we never got this type of thread before, and also Squall-Leonhart who reports these bugs sounds to me like they don't happen on 0.9 and they're regressions.

lol, its WIP, of course there are bugs, xD, reporting them is the first step to fixing them.

And i wouldn't call it super buggy... its not windows vista.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #23 ·
games which use EEProm64K won't work first time via Autodetect, you need to copy a dummy 64KB file for it to write to first time.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #28 ·
Some games have more obscure battery writes i suppose.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #48 ·
Schumi, mind doing a topic split and removing all the unrelated posts ;)
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #50 ·
only if they haven't removed the bug from their alerts.
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #57 · (Edited)
Zelda PH U still not booting in latest svn (must be a SWI issue, since it boots with the arm bios's emulating the swi)


[strike]Zelda PH (all) cannot select profile at start.

Stylus Accuracy broken completely, cannot press the profile button on Zelda, the pokeball button on the pokemon games, Movement selector in naruto path of the ninja.....[/strike]

Caused by Firmware emulation (duh, the firmware contains stylus calibration data, and since it can't be modifed right now...)
 

·
Banned
Joined
·
23,263 Posts
Discussion Starter · #58 ·
New bug

Pokemon P/D/Plat saving does not work at all.
Desmume can load a save created and converted from nogba, or ideas, but is unable to read any it creates itself.

Secondly, saves are created as 256KB(2mb), instead of 512KB(4mb) even when the emulator is set to save at 512KB(4mb)
 
1 - 14 of 14 Posts
Top