Next Generation Emulation banner

1 - 17 of 17 Posts

·
Registered
Joined
·
813 Posts
Discussion Starter · #1 · (Edited)
Beta Date: 21 04 05
Conditions Tested Under:

GSsoft (16 04 05)
SPU2 NullDriver [comp too slow to try with sound]
PADwinKeyB (12 12 2004)
Linuz Cdvdiso 0.5
USA v01.60 bios
REC (same results with INT)

Shows some screens then the beautiful (skipable) video intro... then stops loading with the following message:
isoReadBlock: 2110244 > 2097151
isoReadBlock: 2110245 > 2097151

Status:
Intro
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #3 ·
I made it with dvddecrypter & as I'm on fat32, I cannot have files bigger than 4GB so it's a 2 parts ISO...

So here we got:
-DEMENTO.I00 (4*294*965*248 bytes)
-DEMENTO.I01 (271*910*912 bytes)

+DEMENTO.MDS (4*348 bytes)

But that shouldn't be a problem as, if I remember correctly, I helped you to fix the multi-part detection in cdvdiso about 2 years ago... but maybe it got broken... ;)
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #7 ·
Sorry... that didn't work...
Actually, now it doesn't even load anymore... :(

The output window is filled with :
...
isoReadBlock: 825363498 > 16
isoReadBlock: 825363499 > 16
isoReadBlock: 825363500 > 16
isoReadBlock: 825363501 > 16
...
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #8 · (Edited)
Thanks to Linuz fix to cdvdiso, I was able able to go up to menus & ingame... :thumb:

The 3D is broken and i got a lot of 'unhandled psm : 31' errors in output window... but that's nice anyway... ;)

Status:
Ingame
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #9 ·
With beta from 03 May, I managed to use the progressive display mode (it was crashing before...)... but that didn't help with the 3D... :(
...oh well, that was a try...
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #10 ·
With beta from 31/05/2005 (ff background beta) with REC & gsdx9 0.9, the backgrounds are displayed better now... altough very blury and the 3D characters look like spikey shadows...

"Warning, end with size = 2
Warning, end with size = 2
Warning, end with size = 2
Warning, end with size = 2
Warning, end with size = 2
Warning, end with size = 1" error message looping...
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #12 ·
Ok Linuz... Here it is...
I only copied the beginning of the emulog, as enabling VIF output when having this message froze the emu for 5-10 sec... and resulted in a 24Mb log... :???:
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #13 ·
Beta Date: 01 July 2005
Conditions Tested Under:

GSdx9 0.9
SPU2 NullDriver
SSSPSX pad 1.5
Cdvdpeops 1.2
USA v01.60 bios
REC

Demento is working again & displays gfx like before (blurry+spikey shadow characters)...
No more error message looping...

Status:
Ingame
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #14 · (Edited)
lol
That black shadow definately got feminin barefooted legs...
Come on... pcsx2 team, a bit more and we should be able to see naked Fiona... :wub: :p

EDIT :
Managed to get a face close-up from the cinematics...
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #15 ·
Beta Date: 09 July 2005
Conditions Tested Under:

GSdx9 0.9 MSVC14.00 SSE2 (10 July 2005)
SPU2 NullDriver
SSSPSX pad 1.5
Cdvdpeops 1.2
USA v01.60 bios
INT & REC

Gabest, your latest gsdx9 plugin update completely breaks Demento... The game stops loading at the beginning & fps go up to 78 with a black screen... then nothing more at all...
When I try gssoft again with the same beta, there's no loading error... the game runs ok... strange heh...

Anyway, here's an INT log with VIF, VU0 & HW enabled... I hope you can fix it...

Status:
Broken
 

·
Registered
Joined
·
813 Posts
Discussion Starter · #16 · (Edited)
Beta Date: 21 July 2005 SSE2
Conditions Tested Under:

GSdx9 (SSE2) 0.9 - win,D3D,PS2.0 [10 07 2005]
SPU2 NullDriver
SSSPSX pad 1.5
Cdvdpeops 1.2
USA v01.60 bios
REC

Ingame again...
I just noticed that now, using PS2.0 make fiona looking quite good... well, still a bit spikey...

EDIT: made some more tests... the crashing/not booting bug is still here but it's only with PS3.0...
it looks like the game refuses to boot when using PS3.0 shaders... well, will test with ps2.0 if that increases compatibility... :p

Status:
Ingame
 

·
Registered
Joined
·
27 Posts
parotaku said:
EDIT: made some more tests... the crashing/not booting bug is still here but it's only with PS3.0...
it looks like the game refuses to boot when using PS3.0 shaders... well, will test with ps2.0 if that increases compatibility... :p
If i get this straight, ps1.4 should have the highest compatibility, ps2.0 and 3.0 should be almost equal, but always using ps1.4 is the safest route for now.
 
1 - 17 of 17 Posts
Top