Next Generation Emulation banner

1 - 20 of 23 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
First off... computer specs... not sure if this is sufficient amount of info...

Labtop
Windows Vista Home Premium
Service Pack 1
Intel Core 2 Duo CPU
1.83GHz
2.00GB RAM

First of all, is Eternal SPU Plugin 1.41 still available? I've only been able to find Eternal SPU Plugin 1.50 and I believe in some topics it stated 1.41 had better compatibility rates with FFVII. If it is still available would someone post a link for me please? If 1.50 is the only version available could I get some advice on the settings, because currently a number of attacks, spells, and summons sound... strange along with moving the pointer/cursor/finger/whatever you want to call it. My current settings for it are:

Eternal SPU Plugin 1.50
Audio device: DirectSound
Buffer size:22 or 80
Audio out method: Thread
[ ] Show realtime config window
[X] Wait for XA buffer is free
[ ] Cache VAG decode
Fine tune: 0
Reverb: Neill's
[X] Update before accessing register
[ ] SPU IRQ - Wait CPU action
[ ] SPU IRQ - Force interruption flag7

I've tried multiple settings like checking and unchecking different combinations along with putting in random buffer sizes...



Second of all, I'm not sure if it has to do with my computer specs, but it most likely is... Whenever I cast a spell that makes a large (white/bright?)sphere-like explosion, ex: Lightning 3/ Bahamut ZERO, it causes noticeable lag, but nothing horrendous. I managed to ignore it for a while, but it's getting annoying. The plugin and settings I'm using is:

Plugin: Pete's DX6 D3D Driver 1.1.77
Author: Pete Bernert
GFX card: Mobile Intel(R) 965 Express Chipset Family

Resolution/Color:
- 1280x800 Fullscreen - [32 Bit]

Textures:
- R8G8A8A8
- Filtering: 4
- Hi-Res textures: 2
- VRam size: 0 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 4
- Framebuffer texture: 3
- Framebuffer access: 4
- Alpha multipass: on
- Mask bit: on
- Advanced blending: hardware

Misc:
- Scanlines: off [0]
- Unfiltered FB: off
- Dithering: off
- Screen smoothing: off
- Full vram: on
- Game fixes: on [00000001]


Also I've seen lots of suggestions for fixing those green, cyan, violet, red? (I get all those colors) lines, but I still see the lines... might have skimmed too much, but wouldn't mind some advice for this too.
 

·
クロスエクス
Joined
·
4,662 Posts
Try disabling hi-res texturing for the lag.

The lines on the textures are due to your texture filtering, use the ingame pannel and switch them to see wich one works for you. Although I just disable it.

If using ePSXe v1.7.0, disable the FPS limiter on the plugin.

Also, try using that emulator and the Internal SPU plugin for sound. And, if framerate gets away from the "limit" the sound will distort. If using Eternal, try with SPUAsync:Smooth.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Thanks, the lag is now gone.

The sound is more pleasant now, too.

Unfortunately, all the texture filtering options don't fix the random lines. Options 1,2,3, 5, and 6 create different varieties of colors bordering objects. Option 0 and 4 create random lines.

Thanks for the help on the other issues though.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
try disabling mask bit, it can cause artifacts in some cases although ive never seen it do lines. lines are usually triggered by texture filitering or hi res textures like kross said above.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6 (Edited)
Thanks, but mask bit didn't seem to do much. I've turned off high res texture in the following screen shots. The ones with very few lines are with the texture filtering 0 or 4 setting. The one with the borders of color is with 1, 2, 3, 5, and 6.

Edit: They don't look very clear in these screen shots (probably should have found a better location), but if you need more just tell me. Everything looks fine on the world map, battles, and mini games. It's usually the towns that have these random colored lines all around.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
switch to the OGL1 and use settings as similar to what you have now and see if the lines go away.

edit- btw do you have any other games that do that 3d models over 2d backgrounds sort of thing like FF7 does that these lines show up in as well?
 

·
クロスエクス
Joined
·
4,662 Posts
Do you have Anti-Aliasing, Anisotropic or another "enhancement" forced on your Graphics Card?
Wait... it's an Intel IGP... this is weird.

Hmm.... hit the [FAST] button and try...
Then, hit the [NICE] button and check again.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
I switched to OGL1 and the lines disappeared. Instead it lags horribly and instead of lines, random colored rectangular objects appear and disappear everywhere.

I don't think I have any other games with 3d models over 2d backgrounds... that work with ePSXe. The only other game would be Resident Evil 3, but I haven't been able to get it to work on ePSXe.

No I don't have any "enhancement", that I know of, on my graphics card...

The [FAST] setting didn't do anything except make the graphics look worse, and the [NICE] button just changed it back to how it is with the random lines.

=/
 

·
God of Douchebagness™
Joined
·
9,826 Posts
are your drivers and directx up to date?
 

·
クロスエクス
Joined
·
4,662 Posts
That is odd... you lines are already not "normal" and rectangular objects.... even less normal.

I would guess it's some kind of incompatibility with your driver.
Try updating it from Intel's site, or from your vendor's site (Dell, for example).

Also, if you have no problems with PEOpS Soft plugin, that would be the best option at least. I won't look THAT nice, but it shouldn't have such lines nor glitches.

Or... could it be.... a damaged disc?
 

·
God of Douchebagness™
Joined
·
9,826 Posts
im suspecting it has something to do with directx because if the lines went away in the OGL1 then it might not be related to the actual settings.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #13 (Edited)
My driver should be up to date. Not sure about Directx. How do I check if they are up to date?

Edit: My DirectX version is 10, so I think that's the most recent one, so it's up to date right?
 

·
クロスエクス
Joined
·
4,662 Posts
Dx10 is not compatible with Dx9 and so a compatibility layer is needed and you still need to install Dx9 runtimes.

Check the Dx Web Installer, it should download the files you need to be up to date.

Also, check for new drivers at Intel's site or your vendor's as suggested.
Things that "should" be up-to-date, are often... not.
Even more with Intel IGP's, since their capabilites depend highly on the driver.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #15
I've downloaded the files in the Dx Web Installer and my drivers are already up to date. Still no change.
 

·
クロスエクス
Joined
·
4,662 Posts
Try with an specific ammount of VRAM in the plugin's settings. Try with low and mid values, and try with the real one of yours.

Dunno if it'll work, but it's worth trying.
 

·
Is this thing on?
Joined
·
2,121 Posts
Thanks, but mask bit didn't seem to do much. I've turned off high res texture in the following screen shots. The ones with very few lines are with the texture filtering 0 or 4 setting. The one with the borders of color is with 1, 2, 3, 5, and 6.

Edit: They don't look very clear in these screen shots (probably should have found a better location), but if you need more just tell me.
Not too much an issue. :/
I doubt it would affect gameplay in anyway.
 

·
God of Douchebagness™
Joined
·
9,826 Posts
have you tried playing around with the texture quality setting and/or turning off advanced blending and alpha multipass?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #20 (Edited)
I know it isn't much of an issue, but I wouldn't mind working a little to fix it. =/

Texture quality settings and turning off advance blending didn't help.

I found the source of my problem though. The desktop resolution setting in my plugin is set at 1280x800 and my screen is also set at 1280x800, but when I start the game it starts up as 1280x768(I think) which creates the movie-like black border on the top and bottom of the screen. The screen pixel ratio thing isn't "normal" (ex:1x1 goes to 1x1.5)anymore and creates these lines. I don't know why my game won't start up at 1280x800. Any help on this?


I found this out by choosing other screen sizes, but I would like to play full screen. It's not that I HAVE to, but it would be nice if I found a solution.

Edit: I found out that the screen only changes to 12800x768 when I enter a town or battle. o_O?? When I'm on the world map the screen changes back to 1280x800.
 
1 - 20 of 23 Posts
Top