Next Generation Emulation banner
1 - 20 of 26 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 · (Edited)
Dolphin Crashing

Hey,
I'm sorry if this has been asked countlosly before, but...

I have download the dolphin SVN R3661 a few days ago and am still trying to get it working. Looks like, I need a 'pad'... which appears to be a controller.

I have found nJoy.. obviously, and you guys appear to have a sticky for it. I can't though download it, I can't find where to download it and the links in that thread don't exist.


Is there something I'm missing.

Is there something else I need or is just this one plugin.


I no longer have my actual gc controllers (as if I did, I would be playing on a real gc). SO I would quite like one that uses kyeboard buttons. njoy appears to do this.

When i try to play my few games that I didn't chuck out, all I get is can't INITIAT (sic) PAD plugin.



Thanks for the help in advance.
 

·
No sir, I don't like it.
Joined
·
5,570 Posts
Update your DirectX Runtimes. Link

And yes, this question has indeed been asked no less than eleventy billion times already.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 · (Edited)
FINAL EDIT: Got the PAD's in. Check, but it's cmplaining about a TLB error... I want to play Zoid: battle Legends. I've seen a video on youtube of someone using Dolphin to play the game on the computer. So it IS possible.

Just how?
 

·
Time Lord
Joined
·
1,989 Posts
I don't know how well this game works, but if it really is a TLB error, right click the game on the list and select properties and enable the TLB hack
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
ok... all of the box's were chceked (i.e. all were coloured in).

Enable Dual core
Enable IDle skipping
TLB Hack
Optimize Quantizerws

Force Filtering
Disable Copy to EFB
With Hotkey E
Enable EFB to texture
Safe TExture Cache
Distance Alpha pass
USe XFB

Projection Hack for : None

Use R30 Fix (unchecked)

Emulation State: Perfect
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 · (Edited)
That almost worked.



Thanks for that tip though.


Now... I tick that box leaving the rest coloured in. And run the game. It shows the yellow text at the the top and then doesn't hit the TLB error. Now it waits an extra second and then 'Dolphinhas stopped working.


Apart from the game working on a youtube video, http://spreadsheets.google.com/lv?key=pmSKnNaSoLuNqLjSCSk8rfg indicates that it runs 'perfectly'. once dtk is disabled.


I just tried changing the graphics plugin to direct3d9, same problem.. So it doesn't appear to be graphics related.
 

·
Time Lord
Joined
·
1,989 Posts
Did you update your Directx as suggested earlier? Oh, and 3661 is very outdated. Look for a more recent revision 4500+. TLB games were not fixed before this.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
Sorry for the double post.. but it's a pretty big advancement.

THESE ARE THE SETTINGS I currently have. for those who want to play this game in thef uture... And more importantly now...Anything I have wrong?

Graphics plugin:

native ticked. 2x is empty
windows to 640x480.
aspect ratio of 3:4
not crop

empty for render to main window, enable hotkeys, vsync, use real XFB,
Auto scale IS ticked

Anisotropic 1x
Force linear filter UNTICKED
Antialias OFF
post processor shader OFF


EMPTY BOX - overlay FPS, overlay some statistics, overlay projection statitics, show efb copy regions, overlay texture format,
EMPTY BOX - enable wireframe, disable material lighting, disable texturing,
TICKED: disable destination alpha pass, disable fog

EFB COPY SETTINGS:
disable is empty box
and the point is on copy EFB to system RAM (real) while efb to gl texture (hack) is left empty

UTILITIES:
all empty box - dump textures, dump rendered frames, free look, load hires tectures, dump efb target

Hack: none
EMPTY BOX: use safe texture cache



DSP: enable HLE audio and enable other audio (throttle) are ticked.
dtk music and RE0 audio fix are EMPTY BOX

Audio backend: DSound



GAME SETTINGS:
enable dual core TICK
enable idle skipping EMPTY BOX (when i do anything but empty box the game crashes ALOT faster)
TLB hack tick
Optimize quantizer coloured

Force filtering, disable copy to EFB, enable EFB to RAM, safe texture Cache, distance alpha pass, ufe XFB ALL COLOURED

projection hack NONE

use RE0 fix EMPTY BOX

Emulation state : NOT SET:







The result. The five yellow lines of text appear, then all go one by one, with the CPU being the last one. Then as soon as it goes, the program crashes

I am now using r4525
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
Hey,

Please some help. Any else having problems with Dolphin.
I'm running Vista 32bit if that effects any settings.

Just to recap.


I go into the game, it shows the five lines of text at the top of the screen, all five disappear and then within a few seconds it crashes. (i.e. a crash during Licensed by Nintendo..) doesn't even get to the game loading screen.



Interestingly I tried SuperGCube and it showed the game loading screen and froze on that. So it doesn't work either.
 

·
No$gba Philosopher
Joined
·
548 Posts
That means your game isn't compatible as of current revisions. Wait until Dolphin is compatible with it.

Whatever settings you have made/modify/change, if the game loads, then crash, two obvious things will occur:

1. Game not compatible.
2. There may be something that doesn't make it work. Recheck and try out all different combinations of the settings.

Go google your game and see if it can be run on Dolphin. There should be other players who plays the same game you wanted to play. If it can be run, check to see if they included some instructions or something that aids you.

Don't be afraid of trying Google, it won't bite. You just need to learn to obtain information from other sources, not just here.

I have Vista, 32-bit, and the latest revisions. I can run games pretty well, all according to instructions made from someone else from somewhere else (not from here), even if my graphics card is made by Intel. I will not run games for you.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
please don't be condecending about using Google.. I have been googling and youtubing and trying almost everything I know.

It does run on dolphin.. infact it has run on older version of dolphin.
YouTube - Zoids Battle Legends - Dolphin SVN 3449 x64 That is just one of ther versions. Unfortunately, I don't speak the users langauge and I doubt I could get in contact even if I were to learn another language just to speak to him.


So the GAME IS COMPATIBLE. It's just my setting aren't running it. I thought that it may be a setting I had wrong that someone could point out.

And I have tried other places, but this is one of the best were I can make contact and I guessed that here, were there are people who test this thing and have had years of experience, would be able to provide me with the bit of help i need to get this game oging.

P.S> I found this place by google..
 

·
Banned
Joined
·
23,263 Posts
Recent changes to the core have regressed several games, and fixed others.

if HLE fails, use LLE, if LLE fails, sfh, find something else to play.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #14 · (Edited)
Thanks.

HLE I can see an option for asking me about it. BUt LLE and SFH. Do I need to download other bits?

I also have the 3661 version of it. SO im trying that currently, although with the above ettings, same results.

I am getting better luck now. With the older version, I am getting it so it doesn't automatically crash at some point. It's just stuck.. and a 5% speed.

It gets to Licensed by Nintendo. And whiel doing(2.4/~60(~4%) the screen reads.

It just doesn't do anything. Doesn't crash unless I click STOP in which case in acts me if i wish to stop it, and if i say yes then it crashes.. not that anoying.

Anyway.

It is stuck with 4% despite having been set to quantive whatevers and use both cores.

My CPU according to my gauge in windows are using about 10% each. Memory is 56% used. I have an e6600 cpu with a couple gig of ram and most of that isn't being used. SO it isn't my computer.



What else can I enable to make it go faster.? about 96% fasters
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #18 ·
The problem was that a newer realease had made some games works and others not. I know it works on 3449.

I have been trying 4525, 3661 and 2195.

It apparently also works on 3447. So as such, I'm looking for either of 3449 or 3447 version.

Or possibly the settings if it can work on newer version. I have tried almost every combination of settings and it isn't working. So I was hoping to try to get my hands on something I know does work, hence guartenteing me its the sttings not software if it still doesn't work.
 

·
Registered
Joined
·
379 Posts
What about telling us which games stopped working ? :D
Also, if a game stopped working, it's a GOOD IDEA to report it and it's an even better idea to try a few revisions and find which one broke it ;)

So we can have a chance to fix it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #20 ·
i'm new to this.. this is the only game I have tried.

Squall-leonhart said

Recent changes to the core have regressed several games, and fixed others.

if HLE fails, use LLE, if LLE fails, sfh, find something else to play.

So I was guessing Zoid Battle Legends must be a game that odesn't work on newer revision. I know it worked on older versions. Just don't know about current ones.


How do I use LLE?
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top