Next Generation Emulation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

I have connected two controllers to my PC.
When I launch X360CE, I see a red square next to one of them, and a green square next to the other.
When I go to the red one, and click on its name (Playstation controller) I see the diagnostic numbers moving for axises that i move and button presses being registered. So it seems like it is detecting the actions.

However, when I go to the "general" tab for the controller, I do not see the on-screen joystick respond to my actions, although it does for the other one (with the green icon).
(The in-game only responds to the controller with the green icon, so I do need to get this sorted...)

What causes this red icon? What can I do to fix it?
Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I tried deleting the ini file altogether and then running as admin.
I want to state what works :
- It recognizes it as a playstation controller
- It downloads the correct settings from the internet
- It shows the correct movements in the advanced panel
- If I try to change the mapping by selecting record and then pressing a button on the controller, it works correctly (reassigns buttons etc).

However, the icon color for controller 1 is red, the controller image in "general" remains grayed out and is not recognized in the games.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thank you! I was browsing the sources and found out that red meant that directinput was on and xinput was off and was going to investigate how to change that.
This seems to have done the trick
 
1 - 6 of 6 Posts
Top