Next Generation Emulation banner

1 - 12 of 12 Posts

·
band
Joined
·
4,912 Posts
Discussion Starter · #1 ·
meh

www.ati.com

http://www.ati.com/support/drivers/...uctsXPdriver&submit.x=7&submit.y=8&submit=GO!

New Features

This section provides information on new features introduced in the latest release of the CATALYST™ Software Suite.

The CATALYST™ Software Suite 5.2 introduces 3D setting options to the CATALYST™ CONTROL CENTER system tray. The shortcut allows the user to easily adjust their 3D settings without having to load the CATALYST™ CONTROL CENTER.

The 3D setting submenu will be found in the Adapter menu of the system tray. When a user selects the 3D submenu option, the following options will be made available:

* Anti-Aliasing. Application managed options include, 2X, 4X, 6X, and Enable Temporal Anti-Aliasing
* Anisotropic filtering. Application managed options include, 2X, 4X, 8X, and 16X.
* CATALYST™ A.I. (For RADEON™ 9700 and above). Options include:
o Disabled
o Standard
o Advanced
* Mipmap detail level. Options include; High performance, Performance, Quality, and High quality.
* TRUFORM™. Options include; Application pref, or Always Off.
* Wait for vertical refresh. Options include; Always off, Off unless application specifies, On unless application specifies, and Always on
* Direct3D Setting. Options include; Enable geometry instancing, Support DXT texture formats, and Alternate pixel center
* OpenGL Settings. Options include; Triple buffering, and Force 24-bit Z-buffer depth

Performance Improvements

As with most CATALYST™ releases performance has increased in various situations. The following performance gains are noticed:

* Efficiency improvements in vertex processing have produced performance enhancements in key applications such as Far Cry and 3DMark05 on RADEON™ X850, X800 and X700 series products
* Far Cry "Regulator" and "Volcano" scores are up as much as 20% on RADEON™ X800 PRO at 1600x1200 resolution
* 3DMark05 gains range from 1-3% on RADEON™ X800 series products to as much as 9% on some RADEON™ X700 configurations

Issues Resolved in CATALYST™ Display Driver Version 5.2

The following section provides a summary of the issues that have been resolved in the latest version of CATALYST™. These include:

* 4x4 Evolution2: Attempting to play the game under Windows XP with an ATI RADEON™ X300/X600 series installed no longer results in the operating system failing to respond when the screen is set to 1600x1200 32bpp and OpenGL Renderer is enabled
* 4x4 Evolution 2: Display corruption is no longer noticed when having the display set to 1600x1200 32bpp along with the texture detail set to high and split screen rendering enabled
* Serious Sam: Playing the game under Windows XP results in the display flashing when TRUFORM is enabled
* Sims 2: Playing the game Veronaville under Windows XP while having the desktop set to 1024x768 32bpp along with AA set to 6X no longer results in corruption being noticed in the fields
* Selecting the option; Enable Video Mode, results in the CATALYST™ CONTROL CENTER not being able to return to the default setting for the Enable Video Mode option
* Switching language support for the CATALYST™ CONTROL CENTER no longer results in the slider bar for the engine clock being enabled when the option found in OVERDRIVE™ is locked
* Navigating to View->Define a Custom View and deselecting all options found in the 3D option of the Edit Custom View tab, no longer results in the Standard Settings option remaining selected
* Intermittent failure of the VPU Recover report not being sent is now resolved
* Double-clicking the slider bar found in CATALYST™ A.I. no longer results in the Disable CATALYST™ A.I. option becoming de-selected
* Disabling 3D preview no longer results in the preview continuing to run on a secondary display device
* Having the 3D preview running on the secondary display adapter and attempting change display modes, no longer results in the primary display device displaying a black screen and error messages appearing
* English is no longer the default language when installing the CATALYST™ CONTROL CENTER under Windows XP Japanese version
* The CATALYST™ CONTROL CENTER Version number is now displayed correctly in all localized languages
* The Display Manager Notification dialog box is now displayed in the correct localized language
* The OpenGL driver is no longer disabled after boot up when both AGP Read and PCI Read are disabled

Known Issues for CATALYST™ Display Driver Version 5.2

The following section provides a brief description of known issues associated with the latest version of CATALYST™. These include the following:

* 3DMark2001: A black screen is displayed when launching 3DMark2001 after launching Aquamark3 when the CATALYST™ CONTROL CENTER is installed. Further information on this issue can be found at: www.ati.com/support/infobase/4785.html
* Call of Duty: Corruption is noticed when playing a saved game under Windows XP with an ATI RADEON™ 9100 PRO IGP series installed and having a variety of graphic options provided by the game set high. Further information on this issue can be found at: www.ati.com/support/infobase/4656.html
* Pacific Fighters: Playing the game after playing any track for a short period of time and having the landscape detail set to perfect results in the clouds becoming blocky when flying. Further information on this issue can be found at: www.ati.com/support/infobase/4732.html
* Rainbow six3: Athena Sword: Playing the game under Windows 2000 with an ATI RADEON™ X700 installed results in the game failing to retain its resolution option of 1600x1200 if you Alt-tab out of the game and then Alt-tab back to the game. Further information on this issue can be found at: www.ati.com/support/infobase/4633.html
* Accessing the Problem Report Wizard option from the ATI icon in the system tray results in the Problem Report Wizard not being translated in supported localized languages. Further information on this issue can be found at: www.ati.com/support/infobase/4762.html
* Hesitation and display corruption is noticed when moving a Windows XP Media Center Edition 2005 window from the primary display device to a secondary TV or DVI display device. Further information on this issue can be found at: www.ati.com/support/infobase/4764.html
* Assigning a hotkey to increase the overlay gamma results in the hotkey not functioning properly when playing an MPEG using the Windows Media Player. Further information on this issue can be found at: www.ati.com/support/infobase/4604.html
* The Apply button in the Custom settings of the Advanced mode found under the CATALYST™ CONTROL CENTER Video standard settings, is grayed out when playing a media file. Further information on this issue can be found at: www.ati.com/support/infobase/4606.html
* Entering the Video option found in the Graphic Setting tab of the CATALYST™ CONTROL CENTER results in a missing side scroll bar for the secondary display device when it is connected to an ATI RADEON™ 9800 series under Windows XP. Further information on this issue can be found at: www.ati.com/support/infobase/4765.html
* The Welcome tab found in the CATALYST™ CONTROL CENTER is not completely localized for the Japanese version of Windows XP, or 2000. Further information on this issue can be found at: www.ati.com/support/infobase/4767.html
* Using the CATALYST™ CONTROL CENTER to access the Display Manager results in corruption being seen on top of menu text in the Dutch, French, Spanish, and Portuguese versions of Windows XP. Further information on this issue can be found at: www.ati.com/support/infobase/4768.html
* Currently the TV formats do not correspond to the country selected in the TV properties. Further information on this issue can be found at: www.ati.com/support/infobase/4783.html
* Having a CRT and TV connected to the ATI RADEON™ X850 series results in the TV image quality page not being grayed out when enable video mode is enabled. Further information on this issue can be found at: www.ati.com/support/infobase/4784.html
 

·
No People, No Problems
Joined
·
648 Posts
New drivers i like that.

Downloading
 

·
band
Joined
·
4,912 Posts
Discussion Starter · #3 ·

·
Experenced But New User
Joined
·
866 Posts
Oh, but I have verson 4.12, should I still dl it? :p
 

·
Experenced But New User
Joined
·
866 Posts
dpence said:
I had to drop back to 4.5's Half life 2 didn't like any of the newer releases....
Wasn’t the newer versions made to correct texture problems in HL2? ( I never had any problems with my 9800pro)
 

·
Computer Nerd
Joined
·
162 Posts

·
band
Joined
·
4,912 Posts
Discussion Starter · #10 ·
thing is they didnt really fix that many things....wut is it, 3 games, from which im planning to play only 1 within this next week? (serious sam co-op with some friends coming over this weekend...and even then i dont (know how to..) enable truform in that game)
 

·
Registered
Joined
·
2,167 Posts
D.D. said:
i was wondering in what way hl2 isnt liking these new cats?
9800 Pro
Starting Half Life -2 (Source actually anythign source) would cause a crash back to desktop with a read address error, as well as missing screens before the crash.. Same error that is really predominate at the HL forums. I could get it to work by forcing it into Dx7 mode, but that looked like crap.When I dropped back to 4.05's (I Think, it may be a little newer, can't remember at the moment) Dx9 mode worked, and all is well. And to answer yes, before downgrading I did reinstall drivers as well as DX. Could be something incompatible withthe later releases in my system, but I haven't had time to investigate.
 

·
band
Joined
·
4,912 Posts
Discussion Starter · #12 · (Edited)
Yes, this has happened to me randomly too (muahaha i knew it was the memory read error :) ). Have you tried this : CS Memory Crash Fix

seemed to fix the problem for me. btw it doesnt seem to me to be a problem with anything other than HL2 (source engine) itself. After all, my system just passed a 25 Prime95 run.

EDIT: the thing with the crash is that its completely random. it could happen 5- 10 mins into playing CS or it could not happen even after an hour or so of gaming. thats why i say it *SEEMED* to fix the problem because it hasnt comeback...yet.

EDIT2: or u can try adding "+mat_forcehardwaresync 0" to ur cs launch options from steam
 
1 - 12 of 12 Posts
Top