Next Generation Emulation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
This is another disc swapping related issue with Metal Gear Solid. When the game asks me to insert disc 2, I click on File -> Change Disc -> CDROM, and everything's fine. But, once the next part of the game loads, there is no sound, and whenever I try to contact anyone on the codec (especially Mei Lin for saving!), the game just locks up. The same thing happens when I die, and I choose "Continue" or "Exit." Can someone please help me with this problem? Or else I'll be stuck in the snow forever. :( Thanks.
 

·
Premium Member
Joined
·
3,093 Posts
WARNING - BEFORE TRYING THIS, BACKUP YOUR MEMCARDS ON A SAFE PLACE
Ok, this is risky in a multidisc game, but you could try making a savestate when reaching 2nd cd, quitting the emu, and then restarting it and loading the savestate. Try then to save, maybe it will work.
 

·
Is this thing on?
Joined
·
2,121 Posts
There is another workaround.
Try booting via Disc 2 of the MGS and load the game when you proceed onto the Underground and saving the game from there.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I tried both methods, but still no luck. Thanks for your help though, appreciate it. I'm going to keep experimenting myself, but if anyone knows something else please reply. Thanks again.
 

·
Premium Member
Joined
·
3,093 Posts
Are you using epsxe 1.6.0? If so, try downgrading to 1.5.2, mgs works slightly better for me on it. Alternatively, try on PSXeven or PCSX (hushy is gonna have some fun with this :D )
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Hmm, that sounds like a really good idea, I-Chan. I'll give it a try and tell ya what happens. Thanks. :thumb:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Oi, it seems like downgrading to 1.5.2 doesn't solve the problem. The same thing happens as before. I also tried playing until the next cutscene to see if I could save afterwards, but at the start of the cutscene the game freezes.
 

·
Premium Member
bsnes, ePSXe
Joined
·
21,978 Posts
good old PSXeven saved the day! btw you are gonna want to use the edit button in the future, much cleaner and more respectful than 3 threads :rolleyes: </admin mode off>

ok anyhow, I-Chan, i dont know about you but i have never gotten save states to agree with my MGS. everytime i load a state the sound is gone (like js113 described). i havent passed to Disc2 yet with MGS, in fact i've barely played it on emulator. but i will try PSXeven the next time i do ;)

also, are you using OpenGL? try enabling the PC FPS calculation special fix, see if that helps out the smoothness of the game.
 

·
Premium Member
Joined
·
3,093 Posts
The SS idea was more a shot in the dark than anything. I haven't played through the game in epsxe. I started a couple of times, but i already cleared it 3 times on psx so... ;) . As the switch disc problem has been reported that many times, and config doesn't seem to be the problem, i thought this *might* work. Obviously, i was mistaken :p .
 

·
Is this thing on?
Joined
·
2,121 Posts
js1113 said:
there is no sound, and whenever I try to contact anyone on the codec (especially Mei Lin for saving!), the game just locks up. The same thing happens when I die, and I choose "Continue" or "Exit."
Sorry guys, overlooked this part of the text. :(
What I meant is loading the game you saved from Disc One of the MGS from Disc Two of the MGS.

Somehow, how does this problem occur? Is it the coding of the ePSXe or the SPU plugin? I also met up this problem several times with different games that require the swopping of discs.
 
1 - 11 of 11 Posts
Top