Next Generation Emulation banner
1 - 4 of 4 Posts

· Registered
2 Posts
Discussion Starter · #1 ·
I am facing serious problem in running this game
When I try to run the game, I first it give me an error message:

"Read from invalid memory region (0x37300000)

This is either the game crashing randomly, or a TLB write.Several games uses the TLB to map memory. This function is not supported in Dolphin. Unfortunately there is no way to recover from this error, so Dolphin will not exit abruptly. Sorry!"

I am new in using dolphin so I do some research and tried the following method but I cannot solve the problem:
1. I thought it was a TLB error and tried to use the TLB hack = 1. The error message does not appear but this time dolphin crash.
2. I tried to disable the lock threads to core, enable unlimited Jit Cache, enable use safe texture cache but all these got not effect and I still got the same error message.

I saw others can play this game in dolphin on youtube and many website also said this game is playable on dolphin. I am using Dolphin SVN R 4364 which is the newest version I can find.
I really cannot find any method to solve the problem so I hope anyone who is good on this emu can give me some help.

Thank you

My PC spec
Windows XP Pro ver.2002 sp3
Intel Core 2 Quad Q9650 3GHz
4GB Ram
Nvidia 9600GT 512MB

· Registered
25 Posts
The Compatability List says that you should disable DTK Music. I found it in DSP settings
But when I disable it and start the game with TLB Hack checked, I get these errors:
iCacheJIT: Reading Opcode from 17fffffc. Please report.
then another message:
iCacheJIT: Reading Opcode from 1800000. Please report.
and then another message:
Zero Op - Error flattening 1800000 op 00000000
If I press Yes, then I get the first message again. If I press No, Dolphin Crashes.

Please try Unchecking DTK music. It might work for you. If anyone has a solution to this problem Please post it.

Oh I found a guy who has his working. Here's the link
Zoids Battle Legends Vs problem -

It didn't help me but hopefully it will help you. If you find a solution, Please tell me. I hope I was of some help :).

· Registered
2 Posts
Discussion Starter · #3 ·
First thank you for helping me to find the problem.

I have check my Dolphin's DSP setting, and I found that my DTK Music is already disabled. I got the same error you mentioned in your post.

From the link you post, I try to read through the list of the config. I found that there are some difference in that config when compare to my config.

DSPThread = True
My DSPThread is False and I dont know how to change it to true

GFXPlugin = Plugins/Plugin_VideoOGL.dll
DSPPlugin = Plugins/Plugin_DSP_HLE.dll
Pad1Plugin = Plugins/Plugin_PadSimple.dll
Pad2Plugin = Plugins/Plugin_PadSimple.dll
Pad3Plugin = Plugins/Plugin_PadSimple.dll
Pad4Plugin = Plugins/Plugin_PadSimple.dll
WiiMote1Plugin = Plugins/Plugin_Wiimote.dll
That person got a lot of plugin but I dont have any. Is this cause my dolphin cannot play zoids?
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.