Next Generation Emulation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
I'm trying to get this game to run for my little brother, i have tried numerous Emulators, but none of them seem to work very well. The best one so far i have tried is ePSXe, it runs the game really well untill i get to a section and then it shuts my Emulator off, someone said the Pal version won't run on this, so could someone please tell me if there is a Emulator that this game will run on.

By the way i have tested VGS, ePSXe, Bleem,Psinex, and Bleem.

If anyone know's, please let me know, thanks.
 

·
CoLD InSiDE
Joined
·
2,615 Posts
Originally posted by Johnmiceter

By the way i have tested VGS, ePSXe, Bleem,Psinex, and Bleem.
Well if VGS and epsxe can't run the game then sorry man....!

Ali
 

·
Key To The Universe
Joined
·
2,712 Posts
I'm pretty sure Spyro 3 PAL is protected. Have you tried getting a patch?
 

·
Registered
Joined
·
49 Posts
Discussion Starter #4
No, i haven't tried a patch, what is the patch for by the way.
I tried the Original before i copied it, and it happened in exactly the same spot as the copy, I thought maybe i could get it working on another emulator, or maybe i'm doing something wrong, because someone told me in another Post, that Spyro 3 runs perfectly on ePSXe, so i don't know what is wrong here ?:confused:
 

·
Registered
Joined
·
2,158 Posts
There is at least 3 different versions of the game...If you have the Greatest hits version then you are out of luck as no one has made a patch for it. It won't even run on a modded playstation.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
So how do i know what version i have, in Australia we only have one version, it says, Spyro Year of the Dragon, and it's Pal, that's all i know.

But could someone just confirm if i brought the US version of this game, would it work on ePSXe ? I have to know, because i'm thining about importing it from the US ?
 

·
Key To The Universe
Joined
·
2,712 Posts
Well, I'm playing it perfectly with my US NTSC+patch version. btw, I'm pretty sure the right patch could make it run. Anyway, if you're going to import an american version, you'll have to patch it also.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #8
Zephon, can you please tell me what patch i need , because i have just recently brought the US version, i still got to wait for it to ship though, but after spending all this money on it, i really want to get it to work now, so I'd really appreciate it if you could tell me what patch you used and a link would be great, thanks. :)
 
1 - 8 of 8 Posts
Top