Next Generation Emulation banner
1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Thought some of you may be interested to hear about this new(ish) front end I've been working on. It was originally designed for use in arcade cabinets, but can also be run on your regular PC. The project is still in the beta stage so despite not being as polished or easy to set up as some other front ends, it already supports the following features:

  • Animated game selector
  • Filtering on user-defined categories
  • Video snaps
  • Interface customisation/skinning
  • Multiple emulators/platforms
  • Setup utility to configure controls (keyboard, joystick or mouse)
  • Screen rotation/flipping

Cabrio is a free open source project and, although primarily developed on Linux, a Windows version is also available. It uses common libraries like SDL, OpenGL and ffmpeg, so it shouldn't be too hard to port to other platforms.

Here's a quick video of the front end in action, featuring video snaps from EmuMovies and a selection of my own artwork. More screen shots and info can be found on the project homepage.

(Here's a link to the video if the embedding doesn't work...)
 

·
Ya'ver drink Brazilian bold from fkn dunkn donuts!
Joined
·
7,828 Posts
Wowee, that is seriously nice, I really like the layout, the way to selct games, the videos and how there is static when switching between them, overall it is pretty swish. The only thing that isn't for me are the text styles for the controls at the top of the screen, but that is only a minor detraction for me.

Me likey very much.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Wowee, that is seriously nice, I really like the layout, the way to selct games, the videos and how there is static when switching between them, overall it is pretty swish.
Thanks - I'm glad you like it.

The only thing that isn't for me are the text styles for the controls at the top of the screen, but that is only a minor detraction for me.
Luckily that is just a matter of configuration. Everything you see on screen, from fonts to graphics to layout, is configurable. A few sample themes are included and adding new ones is as simple as creating some graphics and writing (or adapting) a configuration file.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Nice app but sadly is not usable for me atm because when i run the app and move the mouse over the window it closes the app and there´s no info of whats going on.
When the FE is started for the first time, you should be presented with the black setup screen, which will ask you which controls you want to use for different actions. I think you may have inadvertently assigned a mouse movement to the "exit" command, so moving the mouse over the window will quit the application immediately. If you delete the generated "config.xml", you should be able to go through the setup part again and assign a different control.
 

·
Premium Member
Joined
·
17,148 Posts
When the FE is started for the first time, you should be presented with the black setup screen, which will ask you which controls you want to use for different actions. I think you may have inadvertently assigned a mouse movement to the "exit" command, so moving the mouse over the window will quit the application immediately. If you delete the generated "config.xml", you should be able to go through the setup part again and assign a different control.
yes the xml is written and everything goes fine. also the screen shows up and i would really like to do something but as soon as i move the mouse "Baaaaaaaang!" its gone :(

in case it helps(as i don´t get any error messages) am using Win7 x64.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
yes the xml is written and everything goes fine. also the screen shows up and i would really like to do something but as soon as i move the mouse "Baaaaaaaang!" its gone :(
If you wouldn't mind PM-ing me your config.xml file I'll take a look at it.

in case it helps(as i don´t get any error messages) am using Win7 x64.
There may well be some compatibility issues with 64-bit Windows versions - I've only been able to test the build on XP so far.

Unfortunately the window which opens to log error messages also gets killed if the application ends unexpectedly. This is a feature of the MinGW compiler with which this version is built (I really need to get the Windows version to log to a file instead, as important messages can easily be lost this way).

If you're interested in investigating the problem, you may like to try running the application from MSYS which should be able to capture the error messages better.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 · (Edited)
I really need to get the Windows version to log to a file instead, as important messages can easily be lost this way
Here is a new executable that does just that - it creates two files in the current directory: cabrio.out and cabrio.err. Hopefully one of those should contain some kind of error message with which I can troubleshoot this issue.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Looks like there are indeed mouse actions assigned to all the controls. The setup tool is overly sensitive to mouse movement and has probably taken a tiny twitch of the mouse as input for all commands without you even noticing. Best thing to do is either delete your config.xml and redo the setup part (without moving the mouse!) or use the attached config file (this uses the arrow keys as directional controls, enter as "select", backspace as "back" and "escape" as exit). If you want to edit the controls manually, have a look here.

The error log shows you may also have a sound problem. This is all handled by SDL, so I'm not sure how much assistance I can be on that. It may be due to something simple like drivers. I will however look into sorting out the mouse problem shortly.
 

·
Premium Member
Joined
·
17,148 Posts
Looks like there are indeed mouse actions assigned to all the controls. The setup tool is overly sensitive to mouse movement and has probably taken a tiny twitch of the mouse as input for all commands without you even noticing. Best thing to do is either delete your config.xml and redo the setup part (without moving the mouse!) or use the attached config file (this uses the arrow keys as directional controls, enter as "select", backspace as "back" and "escape" as exit). If you want to edit the controls manually, have a look here.

The error log shows you may also have a sound problem. This is all handled by SDL, so I'm not sure how much assistance I can be on that. It may be due to something simple like drivers. I will however look into sorting out the mouse problem shortly.
no problem at all :thumb: i just wanted to report the bug as it renders the entire app un-usable for me atm.. anyways since the project is open source i may take some time and check out what´s really going on and maybe fix it myself ;)
last but not least.. judging by the video(as i haven´t seen it working yet) seems to be an awesome app... keep it up!!

oh, and sorry for the wird sound in the video :p but i had to use my app to record the video to show you what´s going on..
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
no problem at all :thumb: i just wanted to report the bug as it renders the entire app un-usable for me atm.. anyways since the project is open source i may take some time and check out what´s really going on and maybe fix it myself ;)
Yes, thanks for reporting it! It's still early days so I am quite reliant on users to tell me what needs improving. I've seen similar things happen with different types of controls. Some devices seem to supply a constant stream of events even when they're inactive, which can confuse the setup tool. I've catered for some situations, but obviously not all. If you figure out the cause I would of course be interested to hear what it was!

PS. I didn't have my speakers turned on when watching your video, but it was worth doing so! ;-)
 

·
Premium Member
Joined
·
17,148 Posts
i just did a quick check and the problem seems to be the mouse assignment. to fix that you either don´t allow mouse movements to be used in the controls or just don´t allow mouse movements to exit the app. i think that should fix the problem ;) as for the sound it seems to be a compatibility problem rather than a driver problem...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
i just did a quick check and the problem seems to be the mouse assignment. to fix that you either don´t allow mouse movements to be used in the controls or just don´t allow mouse movements to exit the app. i think that should fix the problem ;)
That would do it, but it'd be interesting to know why it's picking up mouse movement when there apparently isn't any. I don't think I can disable mouse controls completely - I have visions of scrolling through the games with the trackball on my arcade control panel ;-)
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top