Next Generation Emulation banner

1 - 20 of 26 Posts

·
Registered
Joined
·
462 Posts
Discussion Starter #1
I posted this way back when this site was still PSXEmu and I'm hoping now that more people have GF3's that someone here has found a solution to it. Alright here's the problem whenever I enable FSAA on the GeForce 3 and have extanded and standard filtering disabled I get all sorts of weird lines over the screen. This problem only occurs with the GeForce 3's multisampling, the problem does not occur on older GeForces. So my question is, has anyone been able to get FSAA to work with a GeForce 3 with no filtering (no extended and no standard filtering), without the glitch? If so, how? I've posted a screenshot so you can all see the problem.

Here are my settings (Quincunx FSAA is enabled in the GeForce 3 display properties):

Plugin: Pete's OpenGL Driver 1.1.54
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: Quadro DCC/AGP/3DNOW!

Resolution/Color:
- 1024x768 Fullscreen - Desktop changing [32 Bit]
- Keep psx aspect ratio: off

Textures:
- R8G8A8A8
- Filtering: 0
- Caching: 2

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- Dithering: on
- Full vram: on
- Game fixes: off [00000300]
 

·
Registered
Joined
·
462 Posts
Discussion Starter #2
BTW the only ways I've found to remove those lines are to either disable FSAA, or enable extended or standard filtering, neither of these options I like, since I like jaggies that FSAA removes, and I can't stand the way filtering messes up the text in games.
 

·
Super Moderator
Joined
·
6,283 Posts
320x240 is the original PSX resolution,although ssome games use another rez.
BTW,which drivers are you using Particleman?
 

·
Registered
Joined
·
1,808 Posts
Yeah,I have seen this topic before.
BTW try to update driver and bios your VGA.
Also chage colors in display properties too.
It might help :)
 

·
Registered
Joined
·
462 Posts
Discussion Starter #8 (Edited)
I'm using the 22.80 drivers, using a resolution that is a multiple of the PSX resolution doesn't seem to help. As for BIOs flashing, I'm not sure if that will do anything since the videocard's BIOs usually only contains stuff like memory timings, core frequencies, volatages etc. So does anyone else with a GeForce 3 have this problem? If someone with a newer GeForce 3 (I got mine during the 1st week the original GF3 was released), doesn't have the problem then I might consider flashing my video bios.
 

·
Super Moderator
Joined
·
6,283 Posts
Originally posted by KojiroTakenashi
You problem lies in Texel Alignment.
Setting it around 7 should help out.
I don't think so,Texel Alignement is for Direct3D and he's using Pete's OGL plugin.
 

·
Registered
Joined
·
462 Posts
Discussion Starter #12
I tried using the Direct3D plugin and messing around with the texel alignment, no luck. Anyways I'm not sure if it's an alignment issue, if you look closely at the screenshot you can see that at certain points the lines, not only go over the background, but over certain polygon characters as well. If it were just an alignment issue for textures it wouldn't make sense for the lines to go over polygons as well.
 

·
Registered
Joined
·
462 Posts
Discussion Starter #14
Yep, I tried all 3 options for FSAA, 2x, Quincunx and 4x, all result in the lines. The 2x and 4x FSAA is not the same as that found on GeForce 1&2's though, the GeForce 3 uses multisampling instead of supersampling, I wish they had left the option for the supersampling found on the GeForce 2, because although multisampling looks better for most games and provides better performance it results in glitches a lot.
 

·
Registered
Joined
·
38 Posts
Lo,

I don't have this problem with my GeForce 3 except if i set the filtering to 1 or 2 : it seems the 2d filtering of pete OGL and Geforce 3 don't mix well (actually i use filtering=4 with quincux fsaa). Have u tried to delete the registry settings of epsxe and epsxe executor and recreate a config from scratch ? (once i had a problem with a "ghost" setting in the registry)

Here are some other things to try :

- Switch on the psx aspect ratio (i was having horizontal line with it off),

- put block transfer in Nvidia control panel (OGL tab),

- use quincux fsaa (best quality and full speed),

- switch off dithering (i think u don't need it with 32bits colors),

- activate fps displaying (i've got some black box with geforce3 fsaa if i don't activate them).


Hope it will help
 

·
Registered
Joined
·
462 Posts
Discussion Starter #16
I don't have the problem with filtering 3 or 4 either, but I'd prefer not to use filtering 3 or 4 since they make the text look weird in a lot of games.
 

·
Registered
Joined
·
38 Posts
I thought text were the same without filtering or with filtering set to 3-4 (no 2d filtering in these case) ?? At least they are for me (i only play ff9 and CC).
Btw, i don't have ur problem with filtering set to 0. here's my config

nv control panel (OpenGL):
  • fast mipmap filtering not checked (i use this only for q3/qw)
  • flipping : block transfer
  • always use 32bpp
  • anisotropic filtering off
  • vsync always off
Plugin: Pete's OpenGL Driver 1.1.54
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 3/AGP/3DNOW!

Resolution/Color:
- 640x480 Fullscreen - Desktop changing [32 Bit]
- Keep psx aspect ratio: on

Textures:
- R8G8A8A8
- Filtering: 0 or 4
- Caching: 2

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: 60

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2 or 1 (slowdown with fsaa activated if FT=2)
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- Dithering: off
- Full vram: off
- Game fixes: on [00000200] (ff9)
 

·
Registered
Joined
·
462 Posts
Discussion Starter #18
Nevermind I do still get the lines with 3 & 4 filtering... I mixed up 1 & 2 with 3 & 4... Are you sure you don't get the boxes with filtering set to zero and FSAA enabled? For me it's not just an epsxe thing. I get it when I try to play the PC version of FF8 or any PC version of Resident Evil as well.
 

·
Registered
Joined
·
462 Posts
Discussion Starter #19 (Edited)
Hey, cool, I figured out how you are able to not get the boxes, you're running at 640x480 combined with keep aspect ratio which for some reason, this combination eliminates the boxes. I would prefer to run at high res with quincunx, but this isn't bad... Thanks for the help! Hopefully Nvidia will fix this nasty bug someday so I can go back to high res with FSAA.

Update: I also find that any multiple of 320x240 (so right now I'm using 960x720) combined with maintain aspect ratio will remove the box outlines. Still hope Nvidia fixes this bug though.
 

·
Registered
Joined
·
462 Posts
Discussion Starter #20 (Edited)
Ok new problem, still related to FSAA though, ok now with the multiples of 320x240 combined with keep psx aspect ratio, I have removed the box outlines. However, another problem remains, In some screens particularly those with paralax I get black boxes around certain layers of the background. These black boxes do not appear when FSAA is disabled. Once again I have attached a screenshot.

I am now using these settings (quincunx FSAA enabled):

Plugin: Pete's OpenGL Driver 1.1.54
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce3/AGP/3DNOW!

Resolution/Color:
- 960x720 Fullscreen - Desktop changing [16 Bit]
- Keep psx aspect ratio: on

Textures:
- R8G8A8A8
- Filtering: 0 - edge clamping supported
- Caching: 3

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 0
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on (hardware)
- Subtractive blending: activated

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- Dithering: off
- Full vram: on
- Game fixes: on [00000200]
 
1 - 20 of 26 Posts
Top