Next Generation Emulation banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hi everyone...

I've just noticed that my cheat lists (created under VBA 1.7.1) work on the 1.7.2 but not on the VBA 1.80 Beta version released (just downloaded it yesterday). When I load a save state (with cheats enabled) in 1.80b previously saved by 1.7.2 and check the list, I find all my entries screwed up (corrupted codes, cut off text, messed up) and sometimes the ROM crashes...

Is this normal ? VBA1.80 being not compatible with 1.7.2 save states and cheat lists... ?

Also: I have noticed that running VBA (1.7.1, 1.7.2) under XP causes massive slowdown on Windows XP (with and without SP2) with the following symptoms:

--> At first when the ROM is just loaded, everything is smooth, but gradually, frameskip auto increases from 0 to 9 and everything gets extremely choppy (with 8-9 fps), have resolved this in 1.7.2 by disabling auto frameskip and setting to 0, but when done on 1.7.1 causes sound to repeat itself each second.... (only happens on XP, 98 is fine)...
-> The slowdown still persists in VBA 1.80 beta but solution works...
-- > Also occurs in the SDL (both 1.7.1 and 1.7.2) but solution works...

-> Second: Exiting VBA (1.7.2 and lower) with a ROM file loaded causes the GUI window to close but the program does not unload itself from memory...

-> Trying to run VBA afterwards causes it to not run with 2 VisualBoyAdvance.exe tasks in Task Manager... (only on XP with and without SP2)...

-> This does not occur with VBA 1.80beta..

But still major slowdown from 1.7.2 especially evident in "Kingdom of Hearts" and some scenes in MegaMan Zero 3 (E)...

-> System Specs:
------------------
-> Intel Pentium 4 2.60GHz HT Northwood
-> i865PE Chipset (MSI 865PE Neo2 :thumb:)
-> 512MB PC3200 Dual Channel DDR Memory (Corsair)
-> MSI nVidia GeForce FX 5200 128MB
-> Windows XP Pro SP2 (DirectX 9.0c)
---------------------------------------------
 
Joined
·
74 Posts
I saw some error messages when started pkmn Ruby in 1.8.0beta but it emulated without problem(
at least I didn't see the problem & what's going on) and installed back the 1.7.2 everything returned back to normal... Another bug??? :(
 
1 - 2 of 2 Posts
Top