Next Generation Emulation banner

"Breath of Fire 4" - Sound

1758 Views 4 Replies 2 Participants Last post by  ego533
This topic was posted before, but there was no response. I feel like a cheese for asking these questions because I know that the people who write the programs have already done alot and the people who answer these questions are using their time. Anyway, the point of that was to say thanks, first.

At several points in the game, like the point at which the sand flier comes over the crest of the hill in the opening sequence, the music cuts out. There IS music here, because I tried it on a real PSX. Also, most of the in-game sounds, like battle voices, ect... cut out. The most noticeable drops are in the cut-scenes. The actual game background music is fine, though.

I've spent countless hours [I have no life, I'm CE major 8) ] trying different configurations, emulators, plugins, and other people's computers and they all have the same problem. I've run it through an ISO, the CD, the Mounted ISO in Daemon Tools, PAL, NTSC, fast, slow. I noticed in Null's 1.35 documents, it mentions this problem, also, for one of the bug reports in an older SPU version. If I had to speculate, I'd say it was something in the way epsxe decodes XA, but I really have no clue.

ANYway, help will be greatly appreciated. The music in the game is supposed to be really good and I don't want to miss out.

Mine savior:
466 Celeron
Santa Cruz sound card (didn't work on SB's either)
Geforce 256
Phillips 24x (NEVER buy phillips CD-ROMS)
A-open Network Card
1 - 5 of 5 Posts
have you tried that new Eternal sound plugin with a high buffer setting?

Yeah, I did just as you posted this... I think I should rephrase the question, actually:

Has anyone NOT had this problem? Does the cut-scene music play for you? What emulator and configuration do you use?

I should also point out why I think it's epsxe. No matter what plugin-ins or other settings I use, it decodes the same length of the XA stream, about 1.5 seconds. This happens whether I use a buffer size of "1" or "999". I'd try other emulators, but most won't even play BOF4 (PSEmuPro...), won'twork (FPSE crashes) or don't play the XA music at all (AdriPSX), so I can't really test it.


Okay, I found out more. Something isn't reading the embedded data in the .str files correctly. Any .str file that is of itself, a single audio/video stream (Like the BOF4 intro scene) runs fine, but when a single .str file holds several streams (Like both BOF3 and 4 cut-scene music and battle voices), it doesn't read the data. I only have Bof3 and 4, so I again can't test any other games (as if that'd help).

Does anybody know about this or of a fix for it?
See less See more
All I can say is that I have exactly the same problem and that I now feel silly for replying with this same bug to a few other posts, instead of reading the most recent posts first :)

No SPU plugin that I could found worked for me, although I didn't experiment with every possible buffer size etc.. :)


If anyone is following this, I found out more stuff. If you start the game through the "run PSX-EXE" option and choose the Slus_013.24 file as the EXE, the XA audio stream will run for about 10 - 20 seconds instead of the .5-1. It'll still cut off in the same place with every plugin.

However, this often freezes the game after the battle XA plays. Also, it ONLY works if the Breath of Fire 4 and Grand Turismo hack fix in the CD-ROM section of the epsxe configuration is turned OFF.
So, it's obviously (as someone posted recently in another BOF4 thread) epsxe, but not necessarily the XA decoding. It may be a CD access flaw combined with the XA decoding. It thinks it's done, but It's not.

If this is of any use to anybody, let me know. I'll stop posting useless trivia on the games if it's only taking up space.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.