Next Generation Emulation banner
1 - 20 of 27 Posts

·
Arnab
Joined
·
38 Posts
Discussion Starter · #1 ·
I'm facing a few problems playing it in Desmume. The touchpad doesn't work, and neither can I start the game because clicking on 'New Game', either by using the mouse, or the keyboard, isn't working!
 

·
Registered
Joined
·
2,614 Posts
Press the button which is assigned to "A" to pass that screen. ;)
 

·
No$gba Philosopher
Joined
·
548 Posts
Look in the menu toolbar. There should be magical buttons waiting for you to set your DeSmuMe up for you.
 

·
Registered
Joined
·
2,614 Posts
Did you tried to change the keyboard keys? If this doesn't work, try to use the emulated firmware, no using the firmware files. ;)
Anyways, what's the version of Desmume which you have?
 

·
Registered
Joined
·
74 Posts
I'm having some emu-crashes with the game, but only recently...is there some runtime stuff one has to install for Desmume to work perfectly? Cuz it's always runtime-errors...
 

·
desmume coder
Joined
·
488 Posts
that game can crash desmume 0.9.4. I dont think it will crash 0.9.5
 

·
Registered
Joined
·
74 Posts
eer...are the recent revs 0.9.4 or 0.9.5, if I might ask a n00bish question like that? ^^
 

·
desmume coder
Joined
·
488 Posts
at this point recent revs are basically 0.9.5. are you crashing on recent revs? We have gone to some great lengths to support this game well in 0.9.5
 

·
Registered
Joined
·
74 Posts
Yeah, I can always see on the commits page that (especially) you are going to some great lengths for the development of Desmume alltogether which I appreciate deeply :)

Yeah, I did have 3 crashes alltogether now...but they don't have anything to do with boss-fights this time. They all spit out something about a runtime error (sorry, didn't write down what it said exactly). One I had with a rev one or two weeks ago - I stopped playing the game until now then - and the other two crashes I had now with r3090. The first came pretty randomly somewhere in the "Underground Tunnel". The second one also, but only when I tried to save state. And the third crash came after Bowser pushes that drilling machine with the Monty Moles out to Toadville...there's a cutscene where you see quiet Toadville at night and the second that the drilling machine comes out of the earth, the emu crashed...I hope it was a random crash, not one that will keep me at that spot...

Could you make use of my save there? I think I can only provide a battery save though cuz of the emu crashing when trying to save state *shrug*
 

·
desmume coder
Joined
·
488 Posts
i hope it was an unrandom crash, one that will keep you at that spot. then you can send me the save and i can find out why it is crashing.

does your emulator always crash when trying to savestate? that isnt normal. is it just on this game?
 

·
Registered
Joined
·
74 Posts
alright. If I find the time today, I will 1. try some state saving and 2. to play to that crashing scene again to see if it still does crash there. I'll report then :)
 

·
Registered
Joined
·
74 Posts
Heya, sorry to disappointcha, but the crash hasn't come again, yet...not when state saving nor after the drilling sequence...
Anyway, I guess it'll come again sooner or later...sooo...my question is still: is there any runtime-something that should be installed for the emulator to work right?

-_- Just got another crash...pretty random...it's always a C++ runtime error...
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Write down the actual error code next time...
 

·
desmume coder
Joined
·
488 Posts
downloading anything isnt going to help you. writing down the error message probably won't either.
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
well if it displays an address surely you can do and check it zeromus? granted that may not fix the error or help much...but it's better than nothing.
 

·
desmume coder
Joined
·
488 Posts
I didnt make the build he's using, I wont know what the address means. Anyway I have better things to do than debug things from a EIP which is more likely than not == 0x00000000
 

·
Hackin 'n Slashin
Joined
·
28,630 Posts
Oh, ok, sorry for the false info and hope then.
 

·
Registered
Joined
·
74 Posts
If I remember right, there wasn't any error code or something anyway...it was just a general message about visual runtime c++ error stuff
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top