Next Generation Emulation banner
1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
im running the newest beta of pcsx2, it runs ff12 near flawless, but i was wondering if anyone else was having trouble with loading from load state? and if possible how to fix it or if there is a work around other than saving in game.. thanks.

edit*
what i mean by load state is file>states>load>slot 1, slot 2, slot 3, etc. in the pcsx2 file drop down menu. not 'in game' saving.


edit*
i'm NOT trying to load games i saved from a different build
 

·
troubleshooter
Joined
·
7,514 Posts
that is called a save state. and no you can't use a save state from a previous build on a new one. Either that or all the plugin configs must be the same for it work but its chance of working is like 3/10.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 · (Edited)
im not trying to use the saved games from last build though i did try that but it didnt work. what im having trouble with is i saved the game, when i go to load from the load state number corresponding with the save state i used it freezes up and i have to close program from the task manager. i can save states, though i guess i can only assume they are being saved at all because i cannot load them.
 

·
troubleshooter
Joined
·
7,514 Posts
the thing is save states only work with the same version aka build of pcsx2, once you change the build or any plugin the save states will not work anymore. No matter which slot you used. It is always better to use the in-game save options. Better try to play the game from the old beta and make an in-game save. After you have done that use the new beta.
 

·
Registered
Joined
·
11 Posts
Dunno if this could help, but when i'm running 1474 with GSdx 1611 saving/loading sstates leads to crash.

UPD:
I was wrong. My problem with sstates was due to gamepad plugins:
SSSPSX 1.7.0 + SSSPSX 1.7.0 = Can't use ESC (hangup) + save/load crash
SSSPSX 1.7.0 + Lilypad 0.10.0 = save/load crash
LilyPad 0.10.0 + Lilypad 0.10.0 = No problems
 

·
Moo.
Joined
·
455 Posts
Savestates will only load in the specific emulator version that they are intended for.

Let's say for example that you saved a "state" in ZSNES version 1.36. This state cannot be loaded into 1.51 or any other version of ZSNES unless the coder specifically writes something to provide support for this (unlikely, particularly with SVNs).

Put more concisely, redlofredlof is right.

Alternatively elcid06, you could simply regress your emulator to whatever plugins, etc. you were using when you saved the state and it should work once again (no guarantees). At this point it would be a good idea to save the game to a memory card plugin and then you can load it from the memory card.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top