Next Generation Emulation banner
1 - 20 of 39 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I was wondering what the best settings for Final fantasy games would be on my rig as they all seem to have slow down no matter what settings i use or missing textures.

FF 7, 8, 9, tactics

Rig:
Pentium 4 @ 1.6 ghz
1 gig ddr 2300 running @ ddr 2100 speeds.
Ati radeon 9600 pro 128 mb

Sorry I know this has probably been asked before but nothing I read worked so far.

Thanks for your time and effort.
 

·
Banned
Joined
·
23,263 Posts
what driver version do you have installed?
 

·
From Love and Limerence
Joined
·
6,574 Posts
what driver version do you have installed?
I'd guess one that needs updated if "the Black triangle in OpenGL syndrom on certain ATi drivers" is what's happening here. Advise number one is to update your GPU drivers.

Update your GPU drivers to correct the missing textures issue.

Also make sure you're using ePSXe 1.7.0 (1.5.2 is okay too, but it's older), as 1.6.0 has issues with at least Final Fantasy IX during some FMVs.

Do note things about visuals and these games.

1. These three Final Fantasy games (VII, VIII, and IX) use 2-D backdrops with 3-D characters, and 3-D world maps and battles, so it's a mixed bag. The key is to concentrate where you want your results. Ideally, everywhere will answer with "the best of both worlds", but it's not as easy as it sounds.

As for Final Fantasy Tactics, I think that game is entirely 2-D, so use a software plug-in (P.E.Op.S.) for that one. It'll be more accurate and look better. I think your CPU should be able to handle it on basic settings (the software plug-ins use the CPU for rendering).

2. There is no one configuration that works for all three of them, as Final Fantasy VIII is a special case. I think what works for Final Fantasy IX would work well for Final Fantasy VII, and vice versa (I never emulated Final Fantasy VII, so I don't know).
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 · (Edited)
Sorry that I forgot to mention that. They are Omega 3.8.442 which is based on Catalyst 7.12 drivers. I'm using ePSXe 1.7.0 and psxeven 0.19.

plugins that I have are are:

Video
pete's d3d 1.77 (dx7)
pete's dx6 d3d 1.77
pete's opengl 1.77
pete's opengl2 2.9
p.e.op.s 1.18, 1.14, 1.16

Sound

p.e.op.s. dsound 1.9
eternal spu 1.41
eternal spu 1.41 lite
eternal spu 1.50

Thanks for your time and effort.
 

·
From Love and Limerence
Joined
·
6,574 Posts
I don't know if it's still the case, but the last person to come here with the latest Omega drivers had the texture issue too. The latest Omega drivers must be based on older ATi drivers that had poor OpenGL support. Updating to official ATi drivers will be needed to fix the textures issue.
 

·
Banned
Joined
·
23,263 Posts
black triangles occurred from 7.10 to 8.6.
 

·
ヒット激しく速く
Joined
·
19,429 Posts
Sorry that I forgot to mention that. They are Omega 3.8.442 which is based on Catalyst 7.12 drivers. I'm using ePSXe 1.7.0 and psxeven 0.19.

plugins that I have are are:

Video
pete's d3d 1.77 (dx7)
pete's dx6 d3d 1.77
pete's opengl 1.77
pete's opengl2 2.9
p.e.op.s 1.18, 1.14, 1.16

Sound

p.e.op.s. dsound 1.9
eternal spu 1.41
eternal spu 1.41 lite
eternal spu 1.50

Thanks for your time and effort.
Old drivers get the latest here:

ATI Catalyst Legacy Display Driver

Make sure you remove the omega ones properly use drive sweeper
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
Ok. I got the newer drivers and cleaned out the old with driver sweeper but the video is still slow as well as the sound. The missing textures don't seem to be around anymore though.

Thanks for your time and effort.
 

·
Banned
Joined
·
23,263 Posts
open up the GFX plugins config and input 128 into the VRAM box.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
I have done that.
pete's ogl2 is set to:

resolution and colors

1024/768 32 bit
internal x 0
internal y 2
stretching mode 2
render mode 0

textures

texture filtering 4
gfx ram 128 mbhi-res textures 0

framerate

use fps limit
fps limit 60

compatability

off screen drawing 1
framebuffer effects 2
framebuffer upload 2

full screen filters

shader effects 1
shader lvl 1

misc

mdec filter
special game fixes

eternal; spu 1.41 Audio

audio device
direct sound buffer 80

audio out method
thread

special game fix
all are checked

misc
wait for xa buffer is free is checked

fine tune is 0

reverb is neills
 

·
Banned
Joined
·
23,263 Posts
set render mode to 2 as well!

and disable all gamefixes except 1 and 2.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #12 ·
Hmm. I'm still haveing the same issues but the opening movie of ff8 after you start a new game seems to be almost running at the right speed. FF7 is still a bit slow though.


Thanks for your time and effort.
 

·
Banned
Joined
·
23,263 Posts
set the x/y resolutions to 1 instead of Y res to 2 and disable the shader filter.
 

·
ヒット激しく速く
Joined
·
19,429 Posts
Use opengl 1.77 plugin with that graphics card at least you can use AA, though if you really want to use opengl2 here is a config:



If you want to use shaders maybe you can use the median shader without getting a performance hit.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #15 ·
Ok. Squall I tried that and it didn't work. Strike I'll try that config, open gl 1.77 causes the who screen to act like it has TV lines through it although scan lines are disabled and it causes ghosting and green lines near things like the trains in the train graveyard.

Sorry I keep bugging you.

Thanks for your time and effort.
 

·
ヒット激しく速く
Joined
·
19,429 Posts
Strange this config should work good for example (play with the resolution to get the best result for you):



If it still does what you say then blame the omega drivers those where fu... up, they where more bugged then the official drivers (although in theory they sounded good), ati making that guy pull the plug on them was one of there best decisions.

You can also try Pete D3D with the same settings and like with those play with the resolution to wield the best result cause i forgot what was a good res on that card.
 

·
From Love and Limerence
Joined
·
6,574 Posts
Try this with the OpenGL (1) plug-in. I used to use this for my old GeForce 4 Ti4200 with 64MB, which is close to the performance of the standard Radeon 9600. It also only had a Pentium III in it. If it could do it, yours can do it.

Plugin: Pete's OpenGL Driver 1.1.76
Author: Pete Bernert
Card vendor: NVIDIA Corporation
GFX card: GeForce 8800 GT/PCI/SSE2

Resolution/Color:
- 640x480 Fullscreen - NO desktop changing [32 Bit] (optional, but keep in mind that these games are a mere 320x224, so the higher from that you go, the more pixelated the 2-D looks in these games)
- Keep psx aspect ratio: on (optional, and essentially no performance difference)

Textures:
- R8G8B8A8 (use the one that says slightly faster on some cards, as that's faster with ATi cards, and the one above it is faster on nVidia cards, if I remember right)
- Filtering: 0 (optional of recommendations 0, 2, or 4, but 5 or 6 may lag)
- Hi-Res textures: 0
- VRam size: 0 MBytes (set to 128)

Framerate:
- FPS limitation: on
- Frame skipping: off
- FPS limit: Auto

Compatibility:
- Offscreen drawing: 3
- Framebuffer texture: 2
- Framebuffer access: 1
- Alpha multipass: on
- Mask bit: on
- Advanced blending: on

Misc:
- Scanlines: off
- Line mode: off
- Unfiltered FB: off
- 15 bit FB: off
- Dithering: off
- Screen smoothing: on (optional, because I like it hiding the pixelation in the 2-D, but it does so by blurring and costs some performance power)
- Screen cushion: off
- Game fixes: on [00000200] (use the applicable ones for Final Fantasy VII and Final Fantasy IX when necessary)
 
1 - 20 of 39 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top