Next Generation Emulation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Since constant crashing, because of the "Item Hang Fix" patch is coming back & forth with builds (I don't know what happened in 2018 'cause I can't even start the games, but in 2069 is back) I've managed to avoid 95% of crashes:

- Unchecking Item Hang Fix (of course).
- Execute Dolphin with -d as a parameter to pop up the debugger.
- Start Game using Play button
- Just before getting a new Item look of for 80295654 (E) or 802904B4 (U) in Delphin-Memory window a set the value to 4E800020.

That's it!!! you can play safely all the time and get new items.

The best could be that if the fix is still needed in future revs, there was a menu option to check and uncheck Patches, like we have for AR Codes.

======================
Intel Core2 Duo
Intel Mobile GPU (256MB)
DirectX9
Dolphin Warnings: 3D accelerator is too old
Graphics card does not support multiple render targets
 

·
Registered
Joined
·
5,309 Posts
Well, it is good but still annoying to me. I prefer it to be playable and no crashing at all.
 

·
aka BhaaL
Joined
·
221 Posts
Code:
[OnFrame]
+$Fix item hang
0x80295654:dword:0x4E800020
Well, thats exactly what this one does.
I never had problems with that tho, so I'm not exactly sure what the difference from your solution to the automated fix is...
 

·
Registered
Joined
·
379 Posts
It seems like the patch for the PAL version of the game is causing all sort of random crashes when doing any sort of things, jumping in the water, opening a door, using the sword etc... can cause the game to crash.

Thus it's better to have it deactivated when you actually want to play more than 1 minute :p so this "trick" of toggling it with the debugger is quite useful ;)
 

·
Registered
Joined
·
1 Posts
Sorry, if it's not the right topic.
It's "normal" if I didn't see "equipment screen" and etc. when I press "start"? I have only black screen :/ (ver. NTSC, Dolphin svn R 2184, opengl)

EDIT: I resolved my problem :) I tried another configuration, and now it's ok.
 

·
Registered
Joined
·
4 Posts
This doesn't really work. In the beginning it was a lot better than with item hang fix on. It crashed, but every 15-20 minutes. But now, at the part when I am in the dragon roost cavern, after I have activated the platform that goes up and down all the time, it started crashing more often. Actually, I can only play for a min. - min. and a half and then it crashes :(

What svn are you using marcosmartin?
 
1 - 8 of 8 Posts
Top