Next Generation Emulation banner
1 - 8 of 8 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Trying to get FF VII working on a new computer. Previously I was running it on my Linux desktop, however I recently built a windows gaming centric computer, so I figured I'd try and get it working there, since it's hooked up to a TV and what not. Well, after a couple days of reading other peoples' posts, I've finally decided to make a post of my own.

Used both ePSXe 1.7 and 1.6

I've used all 3 of Pete's windows video plugins (OpenGL, as well as both the d3d's), the default as well as Pete's sound plugin, and same with the CD plugin.

I only have access to the ISO, as my cd's that I made the copies from are long since dead (why I'm running them on an emulator instead of my playstation). The BIOS boots fine, however when I try and boot the game it just black screens. The logs in both scenarios are almost exactly the same, which is copied below.

I've read that the gpu[0] part is showing that the video plugin isn't loading properly. I've tried adding the program to DEP, as well as setting compatilbilty mode to XP (and removed desktop composition).



The video config is the one that's recommended all over this board, so I haven't bothered posting it. The only thing I can think of is possibly Trendmicro is blocking something with the registry. It has a registry monitoring function, but I've added ePSXe to the exceptions list (anyone have any experience with this?).

machine configuration:

amd 3.0 GHz tri-core (overclocked)
4 gb ram
ATI Radeon 4870 1GB
Integrated fiber optic HD sound

Log (hangs at the end, have to exit the program):

* Running ePSXe emulator version 1.7.0.
* Memory handlers init.
* ePSXe: PSX BIOS loaded [bios\scph7502.bin].
* Loading ISO Format [MDF/BIN/IMG2352] ok
* First/Last track: 1 1
* Track 1: (DATA) - Start 1: (00,02,00) - Length 61:27
* NTSC cdrom detected. (SLU__000.00)
* Doing init gpu[0]...
* Gpu open[0]...
* Direct input init ok.
* Doing spu init...
* Spu open...
 

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
When I run the BIOS is gives the playstation boot animation, along with the sound, and then loads the Memory Card / CD player menu. I can look around the memory cards, though since it's a new computer there's nothing on them.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
Looks like PSX works just fine. I had some stuttering that I didn't have in ePSXe on the linux pc, but I'm assuming that's configuration stuff. I haven't used much other than ePSXe, but I'm tempted to just use what works. Is it worth continuing to trouble shoot ePSXe? It seems more full featured than PSX though, and I haven't tried my xbox360 controller with it yet.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
Here's the config for ePSXe. Don't know if it's related, but the PSX worked all the way up to the initial cut scene (the one with the train and midgar, right after you start a new game) and then errored out.

Plugin: Pete's DX6 D3D Driver 1.1.77
Author: Pete Bernert
GFX card: ATI Radeon HD 4800 Series

Resolution/Color:
- 640x480 Window mode

Textures:
- R5G5B5A1
- Filtering: 6
- Hi-Res textures: 0
- VRam size: 128 MBytes

Framerate:
- FPS limit: on
- Frame skipping: off
- FPS limit: 63.0

Compatibility:
- Offscreen drawing: 2
- Framebuffer texture: 1
- Framebuffer access: 0
- Alpha multipass: on
- Mask bit: off
- Advanced blending: software

Misc:
- Scanlines: off [0]
- Unfiltered FB: off
- Dithering: off
- Screen smoothing: off
- Full vram: off
- Game fixes: on [00000001]
 

· Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
it was set to 0 at some point, but I changed it back and no effect.

I read a couple places on here that "Gpu open[0]..." from my log indicates that the gpu isn't even getting loaded, which means none of these settings really matter yet. Is this true? and if so what could be preventing that other than DEP and running as Administrator (administrator account on this machine is disabled, which gets rid of the need to run things as administrator)?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top