Next Generation Emulation banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi, i admit i'm a bit of a noob at this, i'm trying to get Pcsx2 0.9.4 running on my computer, i have a game that is supposedly compatible, but it runs very slow and crashes after a minute, it also says in the DOS box, "cant find patch" etc, do i need to use a patch for each game? i dont know anything about patches. I have followed guides and im sure its configured correctly

Im using Vista and these are my specs

Processor: Intel® Core™2 Duo CPU E4500 @ 2.20GHz 2.20GHz
RAM: 2 GIG
System type: 32 Bit operating system
Graphic card: Intel(R) 82945G Express Chipset Family

SO.. im not even sure if my computer is compatible? from what ive read i probably have enough ram but my processor might not be sufficient?

Any info or advice from anyone would be greatly appreciated! :)
 

·
troubleshooter
Joined
·
7,514 Posts
can you tell the nae of the game that you are trying to run. Also update your plugins to new versions since old one may be causing a problem.

you don't need patches for all games, games work without patches too.
 

·
Registered
Joined
·
7,330 Posts
There's not a single thing you can do about your issues without a GPU upgrade, and most games will not run at full speed with that CPU. Folderfolder, the GPU is the bottleneck here, a faster CPU would do nothing to help without a new GPU.

Read: http://forums.ngemu.com/pcsx2-forum/62230-pcsx2-0-9-4-faq-frequently-asked-questions.html

945 is PS2.0 "capable", but is very, very slow and Intel's drivers are just ****.

Closed because the FAQ addresses such issues.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top