Next Generation Emulation banner

41 - 59 of 59 Posts

·
GameCube Player!
Joined
·
1,303 Posts
No problem, Ami, have you looked into the flashing parts on some zones in FF8?
 

·
Fluffy Animal Admirer
Joined
·
3,398 Posts
No problem, Ami, have you looked into the flashing parts on some zones in FF8?
Will there ever be an option to increase the window size at all? It's kinda small for a 1920 x 1080 monitor. Or least, a way to fill up the screen without black borders for those who don't care about the 4:3 aspect ratio? Are either of these feasible and/or within reason? Thanks.

I asked about this previous but I think it fell on deaf ears ;)
 

·
クロスエクス
Joined
·
4,662 Posts
Discussion Starter #44
@AmiDog, is it possible to have a list of error codes for the tests that fail? Maybe when doing single tests at least. So as to have a better idea of what's wrong and where to look in order to fix it.

For example, BestCoder's chip8 test result is just a number E##. I know, it's the simple chip8 but the number is super useful to fix the bug.

E 01: 3XNN verify that the jump condition is fair

E 02: 5XY0 verify that the jump condition is fair

E 03: 4XNN verify that the jump condition is fair

E 04: 7XNN check the result of the addition

E 05: 8XY5 verify that VF is set to 0 when there is a borrow

E 06: 8XY5 verify that VF is set to 1 when there is no borrow

E 07: 8XY7 verify that VF is set to 0 when there is a borrow

E 08: 8XY7 verify that VF is set to 1 when there is no borrow

E 09: 8XY1 check the result of the OR operation

E 10: 8XY2 check the result of AND operation

E 11: 8XY3 check the result of the XOR operation

E 12: 8XYE verify that VF is set to the MSB (most significant bit or most left) before the shift and VF does not take value 0 every time

E 13: 8XYE verify that VF is set to the MSB (most significant bit or most left) before the shift and VF does not take value 1 every time

E 14: 8XY6 verify that VF is set to the LSB (least significant bit or most right ) before the shift and VF does not take value 0 every time

E 15: 8XY6 verify that VF is the LSB (least significant bit or most right) before the shift and VF does not take value 1 every time

E 16: FX55 and FX65 verify that these two opcodes are implemented. The error may come from one or the other or both are defects.

E 17: FX33 calculating the binary representation is mistaken or the result is poorly stored into memory or poorly poped (FX65 or FX1E).
Considering that your test is huge, this would be a ton of work indeed. Not only to add the error code, but to also make the file with the description for them. =S
 

·
Registered
Joined
·
7 Posts
I just uploaded a new version of the plugin. Should fix issues with rendering to 15bit/16bit screens and allow games to be pasued and resumed in Epsxe for example. Most time has been spent on investigating and emulating interlace mode properly, but that doesn't make much difference for a frame based plugin, so...

As for a larger window, I'll do something about that for a future release.
 

·
Registered
Joined
·
2 Posts
Hot Wheels - Turbo Racing (USA) [SLUS-00964] -- shows black screen after the intro with AmiDog's GPU 1.9, however, it works with other plugins (gpuBladeSoft, for example).

This Is Football 2 (Europe) [SCES-03070] -- the picture freezes on loading screen (AmiDog's GPU 1.9, works with gpuBladeSoft)
 

·
Registered
Joined
·
2 Posts
Nice plugin amidog, like everyone else says it does need to be bigger well at least in fullscreen mode It needs a way to adjust the brightness too but that's just me though, I don't really know if it is just me but when i'm playing a game the fps drops and the sound gets a lot of static in it every game of mine does this, I'm using amidog's plugin with epsxe spu core 1.9.0 and scph1001 bios, Also if I use a pal bios scph7502 everything works fine in some games, not all, Is it the sound plugin or just a timing issue? what would you recommend for the sound plugin?
 

·
Fluffy Animal Admirer
Joined
·
3,398 Posts
Nice plugin amidog, like everyone else says it does need to be bigger well at least in fullscreen mode It needs a way to adjust the brightness too but that's just me though, I don't really know if it is just me but when i'm playing a game the fps drops and the sound gets a lot of static in it every game of mine does this, I'm using amidog's plugin with epsxe spu core 1.9.0 and scph1001 bios, Also if I use a pal bios scph7502 everything works fine in some games, not all, Is it the sound plugin or just a timing issue? what would you recommend for the sound plugin?
Try a different audio plugin, the default eSPXe isn't that great, at all.
 

·
Registered
Joined
·
2 Posts
Try a different audio plugin, the default eSPXe isn't that great, at all.
thanks for the reply but I did try another audio plugin it did the same thing, so I got P.E.Op.S. Sound Audio Driver 1.10b svn 7 from the playstation data center website and it seems to work a lot better, still a few sound glitches hear and there, nothing like it was lol
 

·
Registered
Joined
·
1 Posts
Hey AmiDog, I wanted to thank you for this plugin, I really enjoy it. It's one of the best video plugins I've tried. The feel, the colors, it has a good speed and video quality is really good. I really hope you manage to get a bigger display while fullscreen, becuase this plugin is awesome! Thanks for your effort and time ;)
 

·
Registered
Joined
·
7 Posts
Yes, I'm still working on the plugin, just not as frequently as I did a while ago. Anyway, I recently got a little testprogram from the mednafen author which passed on the real hardware but failed with my plugin. Turned out to be (yet another) PSX overflow issue, this time related to draw offset and horizontal/vertical coordinates when rendering primitives.

I've updated the my GPU testprogram to trigger the issue, and fixed the emulation. Thus there's a new plugin version available. I also took the time to make use of Direct3D (v9 or later) to allow scaling the image in full screen mode.
 

·
Registered
Joined
·
20 Posts
Thanks for the update. I gave it a quick try in EPSXE and while this new version does appear the scale the image in full screen mode it doesn't appear to be doing it completely. I'm still getting black bars on all four side resulting in a window boxed image. Is this normal?
 

·
Registered
Joined
·
1 Posts
I wanted to add my thanks for this plugin. Really is the best one I've used in a awhile. I was wondering, would it be possible to get an Android port? I know it uses DirectX which (I'm assuming) would make it difficult, but it would be really great to use on the Nvidia Shield.
 

·
Registered
Joined
·
4 Posts
I've been looking for an update. That came just before new year. Thanks Amidog. :)
But I can't figure out how to get fullscreen. Window is now smaller than before.
Any solution. ??
 

·
Registered
Joined
·
4 Posts
I got it working. :)
In Epsxe I could'nt select any scaling etc. But in PCSX reloaded I can select everything. But here the plugin don't work. After configuring in PCSX I went back to Epsxe and here the selected features configured in PCSX were highlighted. That make a perfect almost fullscreen image.
I've set 1024x768 in Nvidia controlpanel to 4:3. Don't know if that's needed. But it's working perfect.
Thank you Amidog for this wonderful plugin.
 
41 - 59 of 59 Posts
Top