Next Generation Emulation banner
1 - 13 of 13 Posts

·
Registered
Joined
·
451 Posts
Discussion Starter · #1 ·
see attached picture. before i moved into my dorm, pcsx2 was working great....almost a constant 60fps and no graphical errors with FFX. Now, seemingly out of the blue, it looks like this. Anyone know what's going on? Help would be greatly appreciated...i already tried re-downloading pcsx2 and everything, but the same thing happens....
 

·
Final Fantasy XXX
Joined
·
2,425 Posts
Turn on FFX HACK...I believe it was F9.
 

·
Anime & jRPGs Addict
Joined
·
933 Posts
If PCSX2 doesn't use FF X hack automatically, then it's odd. 2 things might occur with it. 1st one: PCSX2 doesn't recognise CRC of the game, which can be helped by change/add it to PCSX2 database <the way how to do it was in some thread about probs with russsian FF X>. 2nd one is bad one. Some PCSX2 users had problems with it. When u hit F9 the whole emulator might crash.

Note: link to the thread about probs with russian FF X: http://forums.ngemu.com/pcsx2-official-forum/92979-eternal-ff-x.html?highlight=russian+ffx
 

·
You're already dead...
Joined
·
10,293 Posts
like CaptainZ said, maybe your videocard is too hot and you're getting Artifacts.

if you want to test if its a heat problem, try opening up your computer case and have a big fan blow air inside your case, then run the game and see if it still happens.
 

·
Registered
Joined
·
451 Posts
Discussion Starter · #11 · (Edited)
actually, it was none of these things. somehow, "enable patches" wasn't checked, and frame skipping was enabled. once i enabled patches and switched the frame limiting mode to normal or limit it worked fine. thanks for the help anyways :)

p.s.- the game works great, however the cutscenes are still really bad looking. I remember the cutscenes being glitchy and having artifacts, but now it's just a screenful of garbage.
 

·
Registered
Joined
·
1 Posts
Hmm...

That looks like that what I get when I turn the VU Recompilers of in the CPU settings.

If you disabled them, turn them back on. But since your game shouldnt be able to go any further than the first 3D scene you get, if you disabled them, I fear it's your graphics card.

3 Graphics card that were overheating all the time gave me those errors once, all of them died a week after the artifacts started to show up

Edit: Nevermind, great it works again :)
 

·
Registered
Joined
·
232 Posts
p.s.- the game works great, however the cutscenes are still really bad looking. I remember the cutscenes being glitchy and having artifacts, but now it's just a screenful of garbage.
Turn off AA.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top